summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall Wald <rdwald@gmail.com>2012-11-15 00:33:03 -0500
committerRandall Wald <rdwald@gmail.com>2012-11-15 00:33:03 -0500
commitbfafde1bef9a9998155cc4bd5776bd1d73cb1e72 (patch)
tree444eb2c01b17c565ab3e7877419fdb535a92e7dc
parentAdded new version of xf86-video-intel with the Virtual CRTC patch (diff)
downloadrwald-bfafde1bef9a9998155cc4bd5776bd1d73cb1e72.tar.gz
rwald-bfafde1bef9a9998155cc4bd5776bd1d73cb1e72.tar.bz2
rwald-bfafde1bef9a9998155cc4bd5776bd1d73cb1e72.zip
New ebuild x11-misc/hybrid-screenclone to perform rendering on
integrated video card and run output through ports connected to discrete video card
-rw-r--r--x11-misc/hybrid-screenclone/ChangeLog9
-rw-r--r--x11-misc/hybrid-screenclone/Manifest2
-rw-r--r--x11-misc/hybrid-screenclone/hybrid-screenclone-9999.ebuild31
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/hybrid-screenclone/ChangeLog b/x11-misc/hybrid-screenclone/ChangeLog
new file mode 100644
index 0000000..888ad1a
--- /dev/null
+++ b/x11-misc/hybrid-screenclone/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-misc/hybrid-screenclone
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*hybrid-screenclone-9999 (15 Nov 2012)
+
+ 15 Nov 2012; Randall Wald <rwald@gentoo.org> +hybrid-screenclone-9999.ebuild:
+ New ebuild
+
diff --git a/x11-misc/hybrid-screenclone/Manifest b/x11-misc/hybrid-screenclone/Manifest
new file mode 100644
index 0000000..73fbb6e
--- /dev/null
+++ b/x11-misc/hybrid-screenclone/Manifest
@@ -0,0 +1,2 @@
+EBUILD hybrid-screenclone-9999.ebuild 765 SHA256 b0175672681999eb2a35e81121ea2c708d4c8e6d52c5b8a83ef9fe27ab35ff5d SHA512 33863d9a63391b727ee5539ad8ae0e2d1ef0301ae7ed1a07e0014c62f4bf2c792f67adb5088fa9c2570e8938fb60e0ea6e4296c4a3988a416cfd366d26887817 WHIRLPOOL e5b8a373fc3e00b533532fc877b2fb08f51455306ac32a78542e3b675310486ddb7526d071ddff6bea8ad5299e4092916f37f2f3f8f4daa1ee62e417b3e3a53d
+MISC ChangeLog 262 SHA256 6b38274a501f1e7b48bf672df79f2cace2640530f91fac9e8280c3e21aeb92cb SHA512 54925042063f9013a7bab88e109c5a40b7f8c69e8aea7122c5d26968aa623d6889f82ab3d08e41245c4be6ebd7783eacc921e6f0547ed792a636d1d9b94e4f4b WHIRLPOOL f6e68d9eca3ddfea6eebb95b1ce59fa7484db17611e7f01b27e98e5bbe4a5ac7a6f7af712c6356d80c36dac0dc0cf338991006f782ebbac79265a094801f9fc0
diff --git a/x11-misc/hybrid-screenclone/hybrid-screenclone-9999.ebuild b/x11-misc/hybrid-screenclone/hybrid-screenclone-9999.ebuild
new file mode 100644
index 0000000..ddd23b3
--- /dev/null
+++ b/x11-misc/hybrid-screenclone/hybrid-screenclone-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit git-2
+
+DESCRIPTION="A reimplementation of hybrid-windump with the opposite use-case:
+doing all rendering using the integrated intel card and using the additional
+card just to get more outputs"
+HOMEPAGE="https://github.com/liskin/hybrid-screenclone"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/liskin/hybrid-screenclone.git
+ https://github.com/liskin/hybrid-screenclone.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXtst"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin screenclone
+ insinto /etc/X11/
+ doins xorg.conf.nvidia
+ dodoc README.markdown
+ dodoc screenclone-runx.sample
+}