summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2022-07-10 08:12:50 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2022-07-10 08:12:50 -0500
commite6bae31da5f051872736d52a2c5218be6dde02f8 (patch)
tree2687f01d10ab2ad33b3f7f5a8d33ef849a6f7bd7
parentFix metadata.xml (diff)
downloadsattvik-e6bae31da5f051872736d52a2c5218be6dde02f8.tar.gz
sattvik-e6bae31da5f051872736d52a2c5218be6dde02f8.tar.bz2
sattvik-e6bae31da5f051872736d52a2c5218be6dde02f8.zip
Add dev-python/pynput-1.7.6
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
-rw-r--r--dev-python/pynput/Manifest3
-rw-r--r--dev-python/pynput/metadata.xml11
-rw-r--r--dev-python/pynput/pynput-1.7.6.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pynput/Manifest b/dev-python/pynput/Manifest
new file mode 100644
index 0000000..8bd2295
--- /dev/null
+++ b/dev-python/pynput/Manifest
@@ -0,0 +1,3 @@
+DIST pynput-1.7.6.gh.tar.gz 91413 BLAKE2B 456a9b1d8c69b0e3821bf0bfcb1c1a32ad4c552f8e27925a276612d10a01cb50115a44743e5a7842185138d53b9845af5b8ad3f5c26f137eacd8368323d52956 SHA512 40c0862e4ab11c0f55e5eda9eaf204cecbf21cf801198b3a9b69cb5a8aca6c5d11e40c170f4209ccd0495495a3bdcd69414bf2b2e41ba25e1f87b83585956166
+EBUILD pynput-1.7.6.ebuild 756 BLAKE2B ac67a8e01e4730f4b80933f05fee96946bbd5a4fb17090e3e6bcbb3d90b9bf835d688057d1deb125219be43fcb234efff7faba6fa5f0af1abb9bda85d59be96d SHA512 5bf1053b0c6156a7ddfa1d1e514b0351ecbfc61fa24ccb8d6cef9d41b5c8e6c9fe855fda2e6c921094472077712ba2b89788541e56faa23e4c0cc3dfa0d6229b
+MISC metadata.xml 317 BLAKE2B 638786df37c0c7f94ec16e16cb4770c1c1b5cfb6ac7ed492cd1c38bcb22ead3a07717574fa945fb8cf73afb3d5625716acbde6e27fa78326791759aa7c39d64e SHA512 f201385820099d3d37f4637a3b2ec8b2229db5201324a0cd6652030cd18bf101cd8c68ab8f9787afe3b1e85826621942990095448c2182ceb75f3565d84aa7b1
diff --git a/dev-python/pynput/metadata.xml b/dev-python/pynput/metadata.xml
new file mode 100644
index 0000000..c4fe169
--- /dev/null
+++ b/dev-python/pynput/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pynput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pynput/pynput-1.7.6.ebuild b/dev-python/pynput/pynput-1.7.6.ebuild
new file mode 100644
index 0000000..1e39662
--- /dev/null
+++ b/dev-python/pynput/pynput-1.7.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sends virtual input commands"
+HOMEPAGE="https://github.com/moses-palmer/pynput"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/moses-palmer/pynput.git"
+else
+ SRC_URI="
+ https://github.com/moses-palmer/pynput/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND="
+ dev-python/python-evdev[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ sed -e "s/ + SETUP_PACKAGES,/,/g" -i setup.py || die
+ distutils-r1_src_prepare
+}