summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2020-02-16 14:31:25 -0600
committerDaniel Solano Gómez <gentoo@sattvik.com>2020-02-16 14:31:25 -0600
commit4384a44ffc9f7fe1a48246290ac7c8e0e78f43d3 (patch)
tree52d332d9659c0113d3d5b03596a0f118658a2bcc /app-backup
parentAdd fixed dev-python/future build (diff)
downloadsattvik-4384a44ffc9f7fe1a48246290ac7c8e0e78f43d3.tar.gz
sattvik-4384a44ffc9f7fe1a48246290ac7c8e0e78f43d3.tar.bz2
sattvik-4384a44ffc9f7fe1a48246290ac7c8e0e78f43d3.zip
Add fixed app-backup/dupliciy-0.8.09-r1
Signed-off-by: Daniel Solano <gentoo@sattvik.com>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/duplicity/Manifest4
-rw-r--r--app-backup/duplicity/duplicity-0.8.09-r1.ebuild51
-rw-r--r--app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch15
-rw-r--r--app-backup/duplicity/metadata.xml42
4 files changed, 112 insertions, 0 deletions
diff --git a/app-backup/duplicity/Manifest b/app-backup/duplicity/Manifest
new file mode 100644
index 0000000..aa5aa45
--- /dev/null
+++ b/app-backup/duplicity/Manifest
@@ -0,0 +1,4 @@
+AUX duplicity-0.8.09-fix-docs.patch 549 BLAKE2B 57e20c1f65918e548941ce56969a9a22620bb69577ca1c0168149f28203f0d1068fd6676ade5ef153069823070e033791b4a4e517e79a11d9b33a30f6444c174 SHA512 0ba8e5f02e5e873835ac418d312694ea6b699fc15a2b09828aaa0e2b75bb499d0b054799c619d1bd8bafc97e042eb12e6a64a3c0298158cbc7c2dcd30216f4a2
+DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
+EBUILD duplicity-0.8.09-r1.ebuild 1185 BLAKE2B c6343bf3749462d39b91435a2b871a015e6eb54407c3909906d712eccf615dfd1a0b28c39fe92fefd2ea1cf0408c7dfd3228a73f2c642fa6964fcdc0a17c272c SHA512 772c0e3919791f2b3412c60be9e5fe74fedbd5124166124f60026bc76ce95314c4776c4eba0ba360697a3c19920d12a0523160f0ab6ced856fc9cb329f4fd143
+MISC metadata.xml 1464 BLAKE2B ce583c0e3d2a4b51e8c7afdecd6032bee99fdbbd1a435772587812b1cf87275f9f00d73b7bd6b7f0b7992d2947058e40a1b37fcd775e1c0902e81ebb55d92390 SHA512 bbeb13d7d9728e930eaf2f40fc03ef75234e3c27e532e5e1d069e8da44a0ddfe1b406c53588413a83985b03c94207c8ce1739ccf60e8d114abfde817375ea0fc
diff --git a/app-backup/duplicity/duplicity-0.8.09-r1.ebuild b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
new file mode 100644
index 0000000..07e08b5
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.8.09-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+ net-libs/librsync
+ app-crypt/gnupg
+ dev-python/fasteners[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-arch/par2cmdline
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-docs.patch"
+)
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Duplicity has many optional dependencies to support various backends."
+ elog "Currently it's up to you to install them as necessary."
+}
diff --git a/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch b/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch
new file mode 100644
index 0000000..2141a35
--- /dev/null
+++ b/app-backup/duplicity/files/duplicity-0.8.09-fix-docs.patch
@@ -0,0 +1,15 @@
+--- duplicity-0.8.09/setup.py 2020-01-19 21:15:47.770168177 -0500
++++ duplicity-0.8.09/setup.py 2020-01-19 21:16:53.347709792 -0500
+@@ -51,12 +51,6 @@
+ data_files = [(u'share/man/man1',
+ [u'bin/duplicity.1',
+ u'bin/rdiffdir.1']),
+- (u'share/doc/duplicity-%s' % version_string,
+- [u'COPYING',
+- u'README',
+- u'README-REPO',
+- u'README-LOG',
+- u'CHANGELOG']),
+ ]
+
+ top_dir = os.path.dirname(os.path.abspath(__file__))
diff --git a/app-backup/duplicity/metadata.xml b/app-backup/duplicity/metadata.xml
new file mode 100644
index 0000000..c622ffb
--- /dev/null
+++ b/app-backup/duplicity/metadata.xml
@@ -0,0 +1,42 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ The app-portage category contains software which works with portage or
+ ebuilds.
+ </longdescription>
+ <longdescription lang="de">
+ Die Kategorie app-portage enthält Programme für das Arbeiten mit Portage
+ oder Ebuilds.
+ </longdescription>
+ <longdescription lang="es">
+ La categoría app-portage contiene programas para trabajar con portage
+ o con ebuilds.
+ </longdescription>
+ <longdescription lang="ja">
+ app-portageカテゴリにはportageかebuildと使うソフトウェアが含まれます。
+ </longdescription>
+ <longdescription lang="nl">
+ De app-portage categorie bevat applicaties die samenwerken met portage of
+ direct met ebuilds te maken hebben.
+ </longdescription>
+ <longdescription lang="vi">
+ Nhóm app-portage chứa các ứng dụng liên quan đến
+ portage.
+ </longdescription>
+ <longdescription lang="it">
+ La categoria app-portage contiene programmi per portage o per le ebuilds.
+ </longdescription>
+ <longdescription lang="pt">
+ A categoria app-portage contém programas que funcionam com o portage
+ ou ebuilds.
+ </longdescription>
+ <longdescription lang="pl">
+ Kategoria app-portage zawiera dodatkowe programy do pracy z systemem
+ Portage oraz ebuildami.
+ </longdescription>
+ <use>
+ <flag name="s3">Add support for backing up to S3</flag>
+ </use>
+</pkgmetadata>
+