summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <gentoo@sattvik.com>2022-10-05 20:44:20 -0500
committerDaniel Solano Gómez <gentoo@sattvik.com>2022-10-05 20:44:20 -0500
commit0cc055db10fdf862db1e51900e0109a4b1c0a1f0 (patch)
treed34142a265f271f060cdf45064853c7b201a1ddc /dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild
parentapp-emulation/*: Sync with stefantalpalaru-overlay (diff)
downloadsattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.tar.gz
sattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.tar.bz2
sattvik-0cc055db10fdf862db1e51900e0109a4b1c0a1f0.zip
dev-ruby/*: Add asciidoctor-pdf from guru overlay
Signed-off-by: Daniel Solano Gómez <gentoo@sattvik.com>
Diffstat (limited to 'dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild')
-rw-r--r--dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild b/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild
new file mode 100644
index 0000000..38b4e44
--- /dev/null
+++ b/dev-ruby/prawn-svg/prawn-svg-0.32.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for SVG in Prawn"
+HOMEPAGE="https://github.com/mogest/prawn-svg"
+LICENSE="|| ( MIT Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/css_parser-1.6.0
+ >=dev-ruby/prawn-0.11.1
+ >=dev-ruby/rexml-3.2.0
+ "
+
+ruby_add_bdepend "test? ( dev-ruby/mocha
+ >=dev-ruby/pdf-inspector-1.1.0
+ >=dev-ruby/pdf-reader-1.2
+ )"