summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2010-02-19 09:36:13 -0600
committerDaniel Solano Gómez <daniel@solanogomez.org>2010-02-19 09:36:13 -0600
commit2e73ac65ad0d2943b00753f0927b4b98678fc62a (patch)
tree0fa363f8d2c75713a310eeb3237b521c09f9e20f /x11-misc
parentVersion bump. (diff)
downloadsattvik-2e73ac65ad0d2943b00753f0927b4b98678fc62a.tar.gz
sattvik-2e73ac65ad0d2943b00753f0927b4b98678fc62a.tar.bz2
sattvik-2e73ac65ad0d2943b00753f0927b4b98678fc62a.zip
Add dzen live ebuild
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dzen/Manifest1
-rw-r--r--x11-misc/dzen/dzen-9999.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/dzen/Manifest b/x11-misc/dzen/Manifest
new file mode 100644
index 0000000..defdd30
--- /dev/null
+++ b/x11-misc/dzen/Manifest
@@ -0,0 +1 @@
+EBUILD dzen-9999.ebuild 1912 RMD160 d97371a638e3249e980765c8ffddee0a2b9e4a8b SHA1 af1e52e880575c758508fa6d7ed02d9d3401a3f9 SHA256 0570fd590510241654860dc3b143c197bb42d79d6cd772c962c62ffb535b200a
diff --git a/x11-misc/dzen/dzen-9999.ebuild b/x11-misc/dzen/dzen-9999.ebuild
new file mode 100644
index 0000000..dbbca52
--- /dev/null
+++ b/x11-misc/dzen/dzen-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dzen/dzen-0.8.5.ebuild,v 1.5 2009/09/30 04:45:48 jer Exp $
+
+EAPI="2"
+
+inherit subversion toolchain-funcs multilib
+
+SLOT="2"
+#MY_P="${PN}${SLOT}-${PV}"
+
+DESCRIPTION="a general purpose messaging, notification and menuing program for
+X11."
+HOMEPAGE="http://gotmor.googlepages.com/dzen"
+SRC_URI=""
+ESVN_REPO_URI="http://dzen.googlecode.com/svn/trunk/"
+
+LICENSE="MIT"
+KEYWORDS=""
+IUSE="minimal xft xinerama xpm"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+#S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s:/usr/local:/usr:g" \
+ -e 's:-Os::g' \
+ -e "s:CFLAGS =:CFLAGS +=:g" \
+ -e '/^CC.*/d' \
+ -e 's:^LDFLAGS =:LDFLAGS +=:' \
+ -e "s:/usr/lib :/usr/$(get_libdir) :" \
+ -i config.mk gadgets/config.mk || die "sed failed"
+ sed -i -e "/strip/d" Makefile gadgets/Makefile || die "sed failed"
+ if ! use xft ; then
+ sed -e '/^LIBS/s/ `pkg-config --libs xft`$//' \
+ -e '/^CFLAGS/s/ -DDZEN_XFT `pkg-config --cflags xft`$//' \
+ -i config.mk || die "sed failed"
+ fi
+ if use xinerama ; then
+ sed -e "/^LIBS/s/$/\ -lXinerama/" \
+ -e "/^CFLAGS/s/$/\ -DDZEN_XINERAMA/" \
+ -i config.mk || die "sed failed"
+ fi
+ if use xpm ; then
+ sed -e "/^LIBS/s/$/\ -lXpm/" \
+ -e "/^CFLAGS/s/$/\ -DDZEN_XPM/" \
+ -i config.mk || die "sed failed"
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+
+ if ! use minimal ; then
+ cd "${S}"/gadgets
+ emake || die "emake gadgets failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die
+
+ if ! use minimal ; then
+ cd "${S}"/gadgets
+ emake DESTDIR="${D}" install || die "emake gadgets install failed"
+ dodoc README* || die
+ fi
+}