summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild')
-rw-r--r--media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild
new file mode 100644
index 0000000..f3a8e8a
--- /dev/null
+++ b/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+ SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pillow-9.0.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"