summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-04-04 11:31:23 +0200
committerSven Eden <sven.eden@prydeworx.com>2021-04-04 11:31:52 +0200
commit101c2d1d00d241185da7759883542940eeee0fe1 (patch)
tree8cd5119e28988eae03b3c3d788043ab5de2a4c37 /net-im
parentnet-im/teams-insiders: Remove obsolete ebuild (diff)
downloadseden-101c2d1d00d241185da7759883542940eeee0fe1.tar.gz
seden-101c2d1d00d241185da7759883542940eeee0fe1.tar.bz2
seden-101c2d1d00d241185da7759883542940eeee0fe1.zip
net-im/teams-insiders: V1.4.00.7556 bump
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/teams-insiders/Manifest2
-rw-r--r--net-im/teams-insiders/teams-insiders-1.4.00.7556.ebuild132
2 files changed, 133 insertions, 1 deletions
diff --git a/net-im/teams-insiders/Manifest b/net-im/teams-insiders/Manifest
index 8e97db5..0ac1cdf 100644
--- a/net-im/teams-insiders/Manifest
+++ b/net-im/teams-insiders/Manifest
@@ -1,2 +1,2 @@
-DIST teams-insiders_1.3.00.30857_amd64.deb 76352100 SHA256 0e6ceaddd268d4c098667145f6e8efcfe0be2a65bb54bf0c8256e72e89858b39 SHA512 877cf3c995c7b21dd0357fd8b3ba3a35d95060c34e746aabf17021e5a1c8351a5b2bd5274d35c9e501b2a47b5c93aa07c860ef7da0d46887b0524f227cd0b184 WHIRLPOOL 4ffe1558b90ef9fcb9d105f90eba6e8530c0628f1eb3b181245ea199ed3f8d50eef750883023945def29e0eaa71697265ceaa0d40e934f20ad42fd5c4a3dca60
DIST teams-insiders_1.4.00.4855_amd64.deb 76578824 SHA256 36f7055f1cc7d4ec6dee040a49798cd18c8b0bb4e519372230561ef06302cc7e SHA512 c87cb9702b53464e158f29bf763cf38e6f171c07b5a4a5d4a0dfc15fa6e2cff9d258c61576c7931fb6cd026266b00e40a6e89677b1d57295814e222bf5e7f45a WHIRLPOOL 30310ee4e9006d390d943a64ebc75fd6e5ff69fdbc4a1fcedd16f9f2561106d99853a1d67df3033a3c53cb5ebd79a3cc67683daab612d6a970af121ed52ebd23
+DIST teams-insiders_1.4.00.7556_amd64.deb 77243112 SHA256 c16201f0683feb034d05be679627cc4d65d5f5f165dd97bb3b7847eb81fe29c5 SHA512 1a9dd0882d4aa93a69fc8fed0c40d57ba64432a8a32d727963702e0c49bfdd2b13be9d7a5e65efc271ba26af0708fbbebcb123581ec6d2d39793331da082e7df WHIRLPOOL ee68e86cf03cc1a7d8748c9a4b6384e52cd30d967fc8704174f1e4732238b3a0a637e84c1a03b3585ae9d6902ce1cf39b624a934690c03c2ea4a52fb113f32d0
diff --git a/net-im/teams-insiders/teams-insiders-1.4.00.7556.ebuild b/net-im/teams-insiders/teams-insiders-1.4.00.7556.ebuild
new file mode 100644
index 0000000..3121f54
--- /dev/null
+++ b/net-im/teams-insiders/teams-insiders-1.4.00.7556.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit chromium-2 desktop unpacker xdg-utils
+
+DESCRIPTION="Microsoft Teams Linux Client (Insiders Build)"
+HOMEPAGE="https://teams.microsoft.com/"
+SRC_URI="https://packages.microsoft.com/repos/ms-teams/pool/main/t/${PN}/${PN}_${PV}_amd64.deb"
+
+LICENSE="ms-teams-pre"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist mirror splitdebug test"
+IUSE="system-ffmpeg system-mesa"
+
+QA_PREBUILT="*"
+
+RDEPEND="
+ !net-im/teams
+ app-accessibility/at-spi2-atk
+ app-crypt/libsecret
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libxcb
+ x11-libs/libxkbfile
+ x11-libs/pango
+ system-ffmpeg? ( <media-video/ffmpeg-4.3[chromium] )
+ system-mesa? ( media-libs/mesa[egl,gles2] )
+"
+
+S="${WORKDIR}"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local dest=/usr
+
+ # Remove keytar3, it needs libgnome-keyring. keytar4 uses libsecret and is used instead
+ rm -rf "${WORKDIR}/usr/share/teams-insiders/resources/app.asar.unpacked/node_modules/keytar3" || die
+
+ insinto ${dest}/share
+ doins -r "${S}"${dest}/share/applications
+ doins -r "${S}"${dest}/share/pixmaps
+ doins -r "${S}"${dest}/share/${PN}
+
+ exeinto ${dest}/bin
+ doexe "${S}"${dest}/bin/${PN}
+
+ exeinto ${dest}/share/${PN}
+ doexe "${S}"${dest}/share/${PN}/${PN}
+ doexe "${S}"${dest}/share/${PN}/chrome-sandbox
+ doexe "${S}"${dest}/share/${PN}/crashpad_handler
+
+ # Use system ffmpeg, if wanted. Might crash MS Teams!
+ if use system-ffmpeg; then
+ rm -f "${D}"/${dest}/share/${PN}/libffmpeg.so
+ dosym "${dest}/$(get_libdir)/chromium/libffmpeg.so" "${dest}/share/${PN}/libffmpeg.so"
+ elog "Using system ffmpeg. This is experimental and may lead to crashes."
+ else
+ # Otherwise keep the executable bit on the bundled lib
+ doexe "${S}"${dest}/share/${PN}/libffmpeg.so
+ fi
+
+ # Use system mesa, if wanted. Might Crash MS Teams!
+ if use system-mesa; then
+ rm -f "${D}"/${dest}/share/${PN}/libEGL.so
+ rm -f "${D}"/${dest}/share/${PN}/libGLESv2.so
+ elog "Using system mesa. This is experimental and may lead to crashes."
+ else
+ # Otherwise keep original executable flag
+ doexe "${S}"/${dest}/share/${PN}/libEGL.so
+ doexe "${S}"/${dest}/share/${PN}/libGLESv2.so
+ fi
+
+ # Keep swiftshader, used in GPU-/Head-less systems
+ exeinto ${dest}/share/${PN}/swiftshader
+ doexe "${S}"/${dest}/share/${PN}/swiftshader/libEGL.so
+ doexe "${S}"/${dest}/share/${PN}/swiftshader/libGLESv2.so
+
+ # The overlay handler seems to need executable bits
+ # See: https://microsoftteams.uservoice.com/forums/908686-bug-reports/suggestions/40805257-screen-sharing-broken-on-linux-with-1-3-00-16851#comments
+ exeinto ${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/platform.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/trouter-client.node
+
+ sed -i '/OnlyShowIn=/d' "${S}"${dest}/share/applications/${PN}.desktop
+ domenu "${S}"${dest}/share/applications/${PN}.desktop
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}