summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2020-01-19 08:59:24 +0100
committerSven Eden <yamakuzure@gmx.net>2020-01-19 09:00:12 +0100
commit9d854f5f6b619163eca14738689c7cd3cad4c220 (patch)
tree8d2ce87c01b2baeb1212e574297844059a1359ca /sys-auth
parentsci-libs/ViSP: Tree caught up ; removed (diff)
downloadseden-9d854f5f6b619163eca14738689c7cd3cad4c220.tar.gz
seden-9d854f5f6b619163eca14738689c7cd3cad4c220.tar.bz2
seden-9d854f5f6b619163eca14738689c7cd3cad4c220.zip
sys-auth/elogind: Fix 243.9999 docs patch and add efi USE flag
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sven Eden <yamakuzure@gmx.net>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/elogind-243.9999.ebuild33
-rw-r--r--sys-auth/elogind/files/elogind-236.1-docs.patch24
-rw-r--r--sys-auth/elogind/files/elogind-243.4-docs.patch28
-rw-r--r--sys-auth/elogind/metadata.xml6
4 files changed, 50 insertions, 41 deletions
diff --git a/sys-auth/elogind/elogind-243.9999.ebuild b/sys-auth/elogind/elogind-243.9999.ebuild
index 5bae09c..0f9b8da 100644
--- a/sys-auth/elogind/elogind-243.9999.ebuild
+++ b/sys-auth/elogind/elogind-243.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ EGIT_SUBMODULES=()
LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+acl debug doc +pam +policykit selinux"
+IUSE="+acl debug doc efi +pam +policykit selinux"
COMMON_DEPEND="
sys-apps/util-linux
@@ -42,7 +42,7 @@ PDEPEND="
"
PATCHES=(
- "${FILESDIR}/${PN}-241.1-docs.patch"
+ "${FILESDIR}/${PN}-243.4-docs.patch"
)
pkg_setup() {
@@ -78,27 +78,28 @@ src_configure() {
filter-ldflags $CFLAGS $CXXFLAGS
local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- -Dpamlibdir=$(getpam_mod_dir)
- -Dudevrulesdir="$(get_udevdir)"/rules.d
+ $debugmode
+ --buildtype $(usex debug debug release)
--libdir="${EPREFIX}"/usr/$(get_libdir)
- -Drootlibdir="${EPREFIX}"/$(get_libdir)
- -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
- -Drootprefix="${EPREFIX}/"
+ -Dacl=$(usex acl true false)
-Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
- -Dzshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
- -Dman=auto
- -Dsmack=true
-Dcgroup-controller=openrc
-Ddefault-hierarchy=${cgroupmode}
-Ddefault-kill-user-processes=false
- -Dacl=$(usex acl true false)
- --buildtype $(usex debug debug release)
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Defi=$(usex efi true false)
-Dhtml=$(usex doc auto false)
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ -Dman=auto
-Dpam=$(usex pam true false)
+ -Dpamlibdir=$(getpam_mod_dir)
+ -Drootlibdir="${EPREFIX}"/$(get_libdir)
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
+ -Drootprefix="${EPREFIX}/"
-Dselinux=$(usex selinux true false)
- $debugmode
+ -Dsmack=true
+ -Dudevrulesdir="$(get_udevdir)"/rules.d
+ -Dzshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
)
meson_src_configure
diff --git a/sys-auth/elogind/files/elogind-236.1-docs.patch b/sys-auth/elogind/files/elogind-236.1-docs.patch
deleted file mode 100644
index 1bde53d..0000000
--- a/sys-auth/elogind/files/elogind-236.1-docs.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/meson.build 2018-06-25 08:07:31.459104859 +0200
-+++ b/meson.build 2018-06-25 08:08:21.854103131 +0200
-@@ -2800,20 +2800,7 @@
- # install_data('modprobe.d/systemd.conf',
- # install_dir : modprobedir)
- #endif // 0
--install_data('README',
-- 'NEWS',
-- 'CODING_STYLE',
--#if 0 /// UNNEEDED by elogind
--# 'DISTRO_PORTING',
--# 'ENVIRONMENT.md',
--#endif // 0
-- 'LICENSE.GPL2',
-- 'LICENSE.LGPL2.1',
-- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
--#if 0 /// UNNEEDED by elogind
--# 'TRANSIENT-SETTINGS.md',
--# 'UIDS-GIDS.md',
--#endif // 0
-+install_data('src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
- install_dir : docdir)
-
- #if 0 /// UNNEEDED by elogind
diff --git a/sys-auth/elogind/files/elogind-243.4-docs.patch b/sys-auth/elogind/files/elogind-243.4-docs.patch
new file mode 100644
index 0000000..995a82f
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-243.4-docs.patch
@@ -0,0 +1,28 @@
+--- a/meson.build 2020-01-17 18:34:55.572888655 +0100
++++ b/meson.build 2020-01-17 18:35:42.547887045 +0100
+@@ -3342,24 +3342,7 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+-#if 0 /// elogind has upgraded to markdown, and the NEWS file is useless
+-# 'NEWS',
+-# 'README',
+-#else
+- 'README.md',
+-#endif // 0
+- 'docs/CODING_STYLE.md',
+-#if 0 /// irrelevant for elogind
+-# 'docs/DISTRO_PORTING.md',
+-# 'docs/ENVIRONMENT.md',
+-# 'docs/HACKING.md',
+-# 'docs/TRANSIENT-SETTINGS.md',
+-# 'docs/TRANSLATORS.md',
+-# 'docs/UIDS-GIDS.md',
+-#endif // 0
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
++install_data('src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+ install_dir : docdir)
+
+ #if 0 /// UNNEEDED by elogind
diff --git a/sys-auth/elogind/metadata.xml b/sys-auth/elogind/metadata.xml
index b8aea3f..e556278 100644
--- a/sys-auth/elogind/metadata.xml
+++ b/sys-auth/elogind/metadata.xml
@@ -4,5 +4,9 @@
<maintainer type="project">
<email>freedesktop-bugs@gentoo.org</email>
</maintainer>
- <use />
+ <use>
+ <flag name="efi" restrict="&gt;sys-auth/elogind-243.0">
+ Support rebooting into EFI firmware
+ </flag>
+ </use>
</pkgmetadata>