summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smithdanea@gmail.com>2010-07-29 17:00:08 -0400
committerDane Smith <smithdanea@gmail.com>2010-07-29 17:00:08 -0400
commit09d5bfaba68e23a8735fd16582694b87c980334c (patch)
treef7827488d216affad7619c0b09750ff728c266be
parentUpdated hostmap and plugman (diff)
downloadsmithdanea-09d5bfaba68e23a8735fd16582694b87c980334c.tar.gz
smithdanea-09d5bfaba68e23a8735fd16582694b87c980334c.tar.bz2
smithdanea-09d5bfaba68e23a8735fd16582694b87c980334c.zip
yay homepage
-rw-r--r--dev-ruby/plugman/ChangeLog14
-rw-r--r--dev-ruby/plugman/Manifest3
-rw-r--r--dev-ruby/plugman/plugman-0.0.3.ebuild30
-rw-r--r--net-analyzer/hostmap/hostmap-0.2.2.ebuild11
4 files changed, 6 insertions, 52 deletions
diff --git a/dev-ruby/plugman/ChangeLog b/dev-ruby/plugman/ChangeLog
deleted file mode 100644
index f7d3470..0000000
--- a/dev-ruby/plugman/ChangeLog
+++ /dev/null
@@ -1,14 +0,0 @@
-# ChangeLog for dev-ruby/plugman
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
- 29 Jul 2010; Dane Smith (c1pher) <smithdanea@gmail.com>
- plugman-0.0.3.ebuild:
- Finished(ish) plugman ebuild.
-
-*plugman-0.0.3 (29 Jul 2010)
-
- 29 Jul 2010; Dane Smith (c1pher) <smithdanea@gmail.com>
- +plugman-0.0.3.ebuild:
- New ebuild for plugman. Required Dep. for hostmap.
-
diff --git a/dev-ruby/plugman/Manifest b/dev-ruby/plugman/Manifest
deleted file mode 100644
index 4fd5a14..0000000
--- a/dev-ruby/plugman/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST PlugMan-0.0.3.tar.gz 142599 RMD160 b272891f5862fcc214b0b7b1f90212a6a7d6a4ee SHA1 23f6f6cef08ad186cd72482a8f1e5a6a88e7b134 SHA256 a106cc5dbce65e0f64d986951ab713eacc4130ad63cb0b2147fa26d52cdb0115
-EBUILD plugman-0.0.3.ebuild 636 RMD160 bdb9f6ed2d9eba7bb27f8c3db9d87b85c9e19092 SHA1 f7274f139f97ef65b61053204084097db93b277a SHA256 705b3f8b9b859dfaf6595bc92da8bc96edacc569dfa346bdccf0f6e2bf02fc77
-MISC ChangeLog 399 RMD160 7225c463d2ddd40e66baa769699d04e10dc33eb7 SHA1 b500725f28d8a0bd896c2def6515116c1f9357ef SHA256 05186dc3472631be1c2883a075bbc29cffebac9450728b95bf9804e75d1a6633
diff --git a/dev-ruby/plugman/plugman-0.0.3.ebuild b/dev-ruby/plugman/plugman-0.0.3.ebuild
deleted file mode 100644
index 71004dd..0000000
--- a/dev-ruby/plugman/plugman-0.0.3.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-USE_RUBY="ruby18"
-inherit ruby-fakegem
-
-MY_PN="PlugMan"
-
-DESCRIPTION="Simple plugin manager for ruby"
-HOMEPAGE=""
-SRC_URI="http://rubyforge.org/frs/download.php/33561/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="README PlugMan.pdf"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-all_ruby_prepare() {
- #Normal directory structure helps.
- mv src lib || die
- sed -i 's|src/|lib/|g' Rakefile || die "sed failed"
-}
diff --git a/net-analyzer/hostmap/hostmap-0.2.2.ebuild b/net-analyzer/hostmap/hostmap-0.2.2.ebuild
index 2b0bf0e..4edecd5 100644
--- a/net-analyzer/hostmap/hostmap-0.2.2.ebuild
+++ b/net-analyzer/hostmap/hostmap-0.2.2.ebuild
@@ -4,6 +4,12 @@
EAPI=2
USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="hostmap.conf discovery dictionaries extra"
+RUBY_FAKEGEM_BINWRAP="hostmap"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="doc/Changelog.txt doc/README.pdf doc/THANKS.txt"
+
inherit ruby-fakegem
DESCRIPTION="Automatic hostname and virtual hosts discovery tool written in Ruby"
@@ -15,11 +21,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RUBY_FAKEGEM_EXTRAINSTALL="hostmap.conf discovery dictionaries extra"
-RUBY_FAKEGEM_BINWRAP="hostmap"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="doc/Changelog.txt doc/README.pdf doc/THANKS.txt"
-
ruby_add_rdepend "dev-ruby/net-dns
dev-ruby/plugman"