summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tdb/tdb-1.1.5.ebuild')
-rw-r--r--sys-libs/tdb/tdb-1.1.5.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/sys-libs/tdb/tdb-1.1.5.ebuild b/sys-libs/tdb/tdb-1.1.5.ebuild
new file mode 100644
index 0000000..6ea3018
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.1.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.1.5.ebuild,v 1.4 2009/11/04 11:30:39 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils
+
+DESCRIPTION="Samba tdb"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="python tools tdbtest"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DEPEND="
+ !<net-fs/samba-libs-3.4
+ "
+RDEPEND="${DEPEND}"
+
+BINPROGS="bin/tdbdump bin/tdbtool bin/tdbbackup"
+
+src_prepare() {
+
+ ./autogen.sh || die "autogen.sh failed"
+
+ sed -i \
+ -e 's|SHLD_FLAGS = @SHLD_FLAGS@|SHLD_FLAGS = @SHLD_FLAGS@ @LDFLAGS@|' \
+ -e 's|CC = @CC@|CC = @CC@\
+LDFLAGS = @LDFLAGS@|' \
+ Makefile.in || die "sed failed"
+
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-largefile \
+ $(use_enable python) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake dirs || die "emake dirs failed"
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+ if use tools ; then emake ${BINPROGS} || die "emake binaries failed"; fi
+ if use python ; then emake build-python || die "emake build-python failed"; fi
+ if use tdbtest ; then make bin/tdbtest || die "emake tdbtest failed"; fi
+
+}
+
+src_install() {
+
+ dolib.a sharedbuild/lib/libtdb.a
+ dolib.so sharedbuild/lib/libtdb.so
+
+ if use python || use tools ; then
+ emake install DESTDIR="${D}" || die "emake install failed"
+ fi
+
+ if ! use tools ; then
+ for prog in ${BINPROGS} ; do
+ rm -f "${D}/usr/${prog}"
+ done
+ fi
+
+ if use tdbtest ; then
+ dobin bin/tdbtest
+ fi
+
+}