aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-11-07 17:01:54 +0000
committerStuart Shelton <stuart@shelton.me>2016-11-07 17:01:54 +0000
commitdaf7daba2a4d9344b34a2c13c9ce174278534f3a (patch)
tree7fc20f8a5774e382ebb414fdcba0873448f13f2e /app-shells
parentAdd net-misc/memcached-1.4.33 (diff)
downloadsrcshelton-daf7daba2a4d9344b34a2c13c9ce174278534f3a.tar.gz
srcshelton-daf7daba2a4d9344b34a2c13c9ce174278534f3a.tar.bz2
srcshelton-daf7daba2a4d9344b34a2c13c9ce174278534f3a.zip
Add app-shells/stdlib-2.0.5, update README.md
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/stdlib/Manifest2
-rw-r--r--app-shells/stdlib/stdlib-2.0.5.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/stdlib/Manifest b/app-shells/stdlib/Manifest
new file mode 100644
index 00000000..6a9c9587
--- /dev/null
+++ b/app-shells/stdlib/Manifest
@@ -0,0 +1,2 @@
+DIST stdlib.sh-2.0.5.tar.gz 43431 SHA256 3e3a52c6b146316c1e1656dbb9dcc6d62e71cac1004c00567256f33cce517a65 SHA512 73a2115658fb323d304447aba65c2239eeabe2a8ad7091cee746bbd9a7ac31f08ff98309bae49e73d1553d9afa30a3b026b29fb73c15cbbdffb4fb8c3171f563 WHIRLPOOL ccdd089c9b5fba9bc9e271512b7d550eda9c1f30685821fb010d8b17a9ffd3ac18e7aee839ff3d420141b319df61d6cf8b5f984a78c3c615eac2226b24b5f54b
+EBUILD stdlib-2.0.5.ebuild 872 SHA256 884685f273e1cf5bc6aad730e100e159cd1614e1a5ccdd06abad4f05abcdb859 SHA512 2ec86a15a316fcb003cdf173aa3bb5e7a7e6454db999a11186b4d67831ba680500548147d822508be4711962a940024b77916bd2a6731cc2e6c0368623fc01e6 WHIRLPOOL 1aa4e2be1f4b8e73cf038beb09911a974badc7f1f8cdb77af49a7518878d781a9f581fedbc57e20768ef2a2279e9f1379bf366f27971a73849f1ea1abb4b71a8
diff --git a/app-shells/stdlib/stdlib-2.0.5.ebuild b/app-shells/stdlib/stdlib-2.0.5.ebuild
new file mode 100644
index 00000000..396fd1d7
--- /dev/null
+++ b/app-shells/stdlib/stdlib-2.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Standard functions library for bash"
+HOMEPAGE="https://github.com/srcshelton/stdlib.sh"
+SRC_URI="https://github.com/srcshelton/stdlib.sh/archive/v2.0.5.tar.gz -> stdlib.sh-2.0.5.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 amd64-fbsd sparc-fbsd x86-fbsd"
+KEYWORDS+="~x64-macos ~x86-macos"
+IUSE="colour"
+
+RDEPEND=">=app-shells/bash-2.02"
+
+S="${WORKDIR}"/stdlib.sh-"${PV}"
+
+src_install() {
+ dodoc README.md
+
+ # Use insinto/doins rather than into/dolib as we don't want to use an
+ # architecture-specific library directory
+ insinto /usr/local/lib
+ doins stdlib.sh
+
+ if use colour; then
+ insinto /etc/stdlib
+ newins stdlib-colour.map colour.map
+ fi
+}