summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-05 12:34:18 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-05 12:34:18 +0200
commit6162ab37232752684bce38aa5e3ab95f21aba674 (patch)
treee0a2d5d23b98c1d4074cc1336105ed1c8266c8eb
parentnet-dns/avahi-0.6.30: use systemd.eclass from main-tree (diff)
downloadsystemd-6162ab37232752684bce38aa5e3ab95f21aba674.tar.gz
systemd-6162ab37232752684bce38aa5e3ab95f21aba674.tar.bz2
systemd-6162ab37232752684bce38aa5e3ab95f21aba674.zip
sys-auth/consolekit-0.4.4: use main-tree systemd eclass
Also, synchronize with the ebuild in the main tree.
-rw-r--r--sys-auth/consolekit/Manifest2
-rw-r--r--sys-auth/consolekit/consolekit-0.4.4.ebuild8
2 files changed, 5 insertions, 5 deletions
diff --git a/sys-auth/consolekit/Manifest b/sys-auth/consolekit/Manifest
index 0bcb792..4ef6a57 100644
--- a/sys-auth/consolekit/Manifest
+++ b/sys-auth/consolekit/Manifest
@@ -7,5 +7,5 @@ AUX consolekit-0.4.0-polkit-automagic.patch 841 RMD160 59f6f8d13a6f030107908b592
AUX consolekit-0.4.1-shutdown-reboot-without-policies.patch 1166 RMD160 946969cbc2c86bf81f151cbefae022ea95971a57 SHA1 1db7f74e84146c738d5de4b5f835376a1a394280 SHA256 78e7e3b71c34c9a0b2eef58c55c8ac6e34fd4ee0ddb03d20c9adf138d2dafbc9
AUX pam-foreground-compat.ck 389 RMD160 b72a66d5fde612a825fb60f0f1402a0665cc6d81 SHA1 25c3e54e326606e6c476e0dbb9637e2e551a6ccc SHA256 0b5b22641e2b138f4e9dfff9790df9fedaf2f760cc3d878ee1e94c2fd52edea9
DIST ConsoleKit-0.4.4.tar.bz2 424699 RMD160 e9a37d8c71a9c8d09646be5d105ed9ecf45e9b5a SHA1 163ee0e6308b94dd4712cc64d5a34e8c9007d5d4 SHA256 f0c00969fb6fe7d628071f0f43ac0d411982a5e798d7dc31747caa772c9716ae
-EBUILD consolekit-0.4.4.ebuild 2788 RMD160 9cbbf720bc8fdcbfe6120d46bb43a28d5655776c SHA1 3d150c813b802dcac60fe7980e4494e9dbbdc833 SHA256 4d27a7a58d5b4a7165201ae1c443a106000bad98f284a825a266a286e4cc2f2c
+EBUILD consolekit-0.4.4.ebuild 2765 RMD160 fbb250ee8956bbcb8e4f4f9eacf0fbdbb61591e6 SHA1 fa641259849d9509ed2dd6548b097116436db671 SHA256 f676fc66b84aca544c2074f9da8e07679cfa89983d2e5b507669793c7165c861
MISC metadata.xml 313 RMD160 d6625d48d47f8417bccec2c9ccf0524b5bbd58e5 SHA1 7934855c56b41e669b8070577a7838e3037dd1a1 SHA256 a59fecba81d8bb5f8cc5d32815107f8087d3c1274c72dc42061bc0a720b0504b
diff --git a/sys-auth/consolekit/consolekit-0.4.4.ebuild b/sys-auth/consolekit/consolekit-0.4.4.ebuild
index 592a92a..c5636ff 100644
--- a/sys-auth/consolekit/consolekit-0.4.4.ebuild
+++ b/sys-auth/consolekit/consolekit-0.4.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.4.ebuild,v 1.1 2011/02/26 11:05:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/consolekit/consolekit-0.4.4.ebuild,v 1.8 2011/04/23 16:58:35 ssuominen Exp $
EAPI=3
-inherit autotools eutils linux-info multilib pam systemd-local
+inherit autotools eutils linux-info multilib pam systemd
MY_PN=ConsoleKit
MY_P=${MY_PN}-${PV}
@@ -14,7 +14,7 @@ SRC_URI="http://www.freedesktop.org/software/${MY_PN}/dist/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug doc kernel_linux pam policykit test"
RDEPEND=">=dev-libs/dbus-glib-0.88
@@ -57,7 +57,7 @@ src_configure() {
$(use_enable doc docbook-docs) \
$(use_enable debug) \
$(use_enable policykit polkit) \
- $(use_with_systemdsystemunitdir) \
+ "$(systemd_with_unitdir)" \
--with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
--with-pam-module-dir=$(getpam_mod_dir)
}