summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Huber <huber@crans.org>2010-12-29 17:53:50 +0100
committerOlivier Huber <huber@crans.org>2010-12-29 17:53:50 +0100
commit0ff1fe272813bb5b7f02dbce0711fef9bc8f6d1c (patch)
tree4b25abcbd4cf5d70a9681d8fecb222370e16d86f
parent[dev-ml/obus] initial import (diff)
downloadxhub-0ff1fe272813bb5b7f02dbce0711fef9bc8f6d1c.tar.gz
xhub-0ff1fe272813bb5b7f02dbce0711fef9bc8f6d1c.tar.bz2
xhub-0ff1fe272813bb5b7f02dbce0711fef9bc8f6d1c.zip
[dev-ml/ocaml-usb] initial import
-rw-r--r--dev-ml/ocaml-usb/Manifest2
-rw-r--r--dev-ml/ocaml-usb/ocaml-usb-1.1.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ocaml-usb/Manifest b/dev-ml/ocaml-usb/Manifest
new file mode 100644
index 0000000..61994f5
--- /dev/null
+++ b/dev-ml/ocaml-usb/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-usb-1.1.0.tar.gz 49997 RMD160 2089e0653015416205f7cdcd7f6e82db784e695d SHA1 fc684ead618877efb17963f024e64b8e302f0f3a SHA256 63a4817376433d736fc7db7d10cf5868c701bc8c3c7be41df822900be88dda06
+EBUILD ocaml-usb-1.1.0.ebuild 841 RMD160 20e3d1931c00d484b804ff9c5253da9b071d7ad1 SHA1 dd929fbd0c1fe87faa12a6a39dd0f184f677045b SHA256 9612fb326b01c8181888bcf3a76919b63afa76fbb09ed66ddc47a9b27aaebbdf
diff --git a/dev-ml/ocaml-usb/ocaml-usb-1.1.0.ebuild b/dev-ml/ocaml-usb/ocaml-usb-1.1.0.ebuild
new file mode 100644
index 0000000..20a1301
--- /dev/null
+++ b/dev-ml/ocaml-usb/ocaml-usb-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit findlib oasis eutils
+
+DESCRIPTION=""
+HOMEPAGE="https://forge.ocamlcore.org/projects/ocaml-usb/"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/540/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="${DEPEND}
+>=dev-lang/ocaml-3.11
+>=dev-libs/libusb-1.0
+>=dev-ml/lwt-2.0.0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ chmod +x configure
+ oasis_src_configure
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to build the documentation"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use doc; then
+ dohtml _build/usb.docdir/*.html
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}