summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-11 05:15:33 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-11 05:15:33 +0000
commitd7e93a58f20a090ecf007d0c4652c0da070eecfd (patch)
treeff95ed1e37fcb59eb5929390a1d300d3a7810161
parentversion bump (diff)
downloadgentoo-2-d7e93a58f20a090ecf007d0c4652c0da070eecfd.tar.gz
gentoo-2-d7e93a58f20a090ecf007d0c4652c0da070eecfd.tar.bz2
gentoo-2-d7e93a58f20a090ecf007d0c4652c0da070eecfd.zip
version bump
-rw-r--r--games-arcade/rocksndiamonds/ChangeLog11
-rw-r--r--games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.61
-rw-r--r--games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild46
-rw-r--r--games-fps/doomlegacy/ChangeLog7
-rw-r--r--games-fps/doomlegacy/doomlegacy-1.41.ebuild86
-rw-r--r--games-fps/doomlegacy/files/1.41-errno.patch30
-rw-r--r--games-fps/doomlegacy/files/1.41-makefile.patch105
-rw-r--r--games-fps/doomlegacy/files/digest-doomlegacy-1.413
8 files changed, 285 insertions, 4 deletions
diff --git a/games-arcade/rocksndiamonds/ChangeLog b/games-arcade/rocksndiamonds/ChangeLog
index 4e958ebca8be..bdd16a3d0d59 100644
--- a/games-arcade/rocksndiamonds/ChangeLog
+++ b/games-arcade/rocksndiamonds/ChangeLog
@@ -1,14 +1,19 @@
# ChangeLog for games-arcade/rocksndiamonds
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/ChangeLog,v 1.4 2003/09/15 21:58:44 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/ChangeLog,v 1.5 2003/10/11 05:12:08 vapier Exp $
+
+*rocksndiamonds-3.0.6 (11 Oct 2003)
+
+ 11 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
+*rocksndiamonds-3.0.4 (15 Sep 2003)
15 Sep 2003; Michael Sterrett <msterret@gentoo.org>
rocksndiamonds-2.1.1.ebuild, rocksndiamonds-3.0.0.ebuild,
rocksndiamonds-3.0.2.ebuild:
removed old versions
-*rocksndiamonds-3.0.4 (15 Sep 2003)
-
15 Sep 2003; Michael Sterrett <msterret@gentoo.org>
rocksndiamonds-3.0.4.ebuild:
version bump
diff --git a/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.6 b/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.6
new file mode 100644
index 000000000000..c03d31faa576
--- /dev/null
+++ b/games-arcade/rocksndiamonds/files/digest-rocksndiamonds-3.0.6
@@ -0,0 +1 @@
+MD5 f848f40b91a0128b8022c4fb91154a5f rocksndiamonds-3.0.6.tar.gz 6843282
diff --git a/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild
new file mode 100644
index 000000000000..1661bc0bdfb9
--- /dev/null
+++ b/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rocksndiamonds/rocksndiamonds-3.0.6.ebuild,v 1.1 2003/10/11 05:12:08 vapier Exp $
+
+inherit games flag-o-matic
+
+DESCRIPTION="A Boulderdash clone"
+HOMEPAGE="http://www.artsoft.org/rocksndiamonds/"
+SRC_URI="http://www.artsoft.org/RELEASES/unix/rocksndiamonds/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="X? ( virtual/x11 )
+ sdl? ( >=media-libs/libsdl-1.2.3
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-image-1.2.2 )
+ || ( X? ( ) sdl? ( ) virtual/x11 )"
+
+src_compile() {
+ replace-flags -march=k6 -march=i586
+
+ local makeopts="RO_GAME_DIR=${GAMES_DATADIR}/${PN} RW_GAME_DIR=${GAMES_STATEDIR}/${PN}"
+ if [ `use X` ] || [ -z "`use X``use sdl`" ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" x11 || die
+ mv rocksndiamonds{,.x11}
+ fi
+ if [ `use sdl` ] ; then
+ make clean || die
+ make ${makeopts} OPTIONS="${CFLAGS}" sdl || die
+ mv rocksndiamonds{,.sdl}
+ fi
+}
+
+src_install() {
+ dogamesbin rocksndiamonds.{sdl,x11}
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -R graphics levels music sounds ${D}/${GAMES_DATADIR}/${PN}/
+
+ newman rocksndiamonds.{1,6}
+ dodoc CHANGES CREDITS HARDWARE README TODO docs/elements/*.txt
+
+ prepgamesdirs
+}
diff --git a/games-fps/doomlegacy/ChangeLog b/games-fps/doomlegacy/ChangeLog
index 8bda8a2273b9..0bb074756a83 100644
--- a/games-fps/doomlegacy/ChangeLog
+++ b/games-fps/doomlegacy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/doomlegacy
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/ChangeLog,v 1.2 2003/09/10 16:05:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/ChangeLog,v 1.3 2003/10/11 05:15:33 vapier Exp $
+
+*doomlegacy-1.41 (11 Oct 2003)
+
+ 11 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage.
*doomlegacy-1.40-r2 (13 Aug 2003)
diff --git a/games-fps/doomlegacy/doomlegacy-1.41.ebuild b/games-fps/doomlegacy/doomlegacy-1.41.ebuild
new file mode 100644
index 000000000000..e841c7d70cd6
--- /dev/null
+++ b/games-fps/doomlegacy/doomlegacy-1.41.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomlegacy/doomlegacy-1.41.ebuild,v 1.1 2003/10/11 05:15:33 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Doom legacy, THE doom port"
+HOMEPAGE="http://legacy.newdoom.com/"
+SRC_URI="mirror://sourceforge/doomlegacy/legacy_${PV/./}_src.tar.gz
+ mirror://sourceforge/doomlegacy/legacy.dat.gz
+ http://www.lbjhs.net/~jessh/lsdldoom/doom1.wad.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+DEPEND="x86? ( >=dev-lang/nasm-0.98 )
+ >=sys-apps/sed-4
+ virtual/opengl
+ virtual/x11"
+
+S=${WORKDIR}/legacy_${PV//.}_src
+
+src_unpack() {
+ unpack ${A}
+ mkdir bin
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+ epatch ${FILESDIR}/${PV}-makefile.patch
+
+ # disable logfile writing
+ sed -i 's:#define LOGMESSAGES::' doomdef.h || die 'sed doomdef.h failed'
+
+ # make sure the games can find the wads/data files
+ sed -i \
+ "/#define DEFAULTWADLOCATION1s/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ linux_x/i_system.c
+
+ # move opengl lib file because it's not useful to anyone else
+ sed -i "s:\"r_opengl:\"${GAMES_LIBDIR}/${PN}/r_opengl:" linux_x/i_video_xshm.c
+
+ cd linux_x/musserv
+ make -f Makefile.linux clean
+}
+
+src_compile() {
+ # this is ugly but it's late (here) and it works
+ local useasm=
+ [ `use x86` ] && useasm="USEASM=1"
+ local redosnd=0
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || redosnd=1
+ if [ ${redosnd} -eq 1 ] ; then
+ cd linux_x/sndserv
+ make clean || die "clean snd srv failed"
+ make EXTRAOPTS="${CFLAGS}" || die "snd serv failed"
+ fi
+ cd ${S}
+ make \
+ EXTRAOPTS="${CFLAGS}" \
+ LINUX=1 \
+ X=1 \
+ ${useasm} \
+ || die "build failed"
+}
+
+src_install() {
+ dogamesbin \
+ linux_x/musserv/linux/musserver \
+ linux_x/sndserv/linux/llsndserv \
+ ${WORKDIR}/bin/llxdoom
+ exeinto ${GAMES_LIBDIR}/${PN}
+ doexe ${WORKDIR}/bin/r_opengl.so
+
+ insinto ${GAMES_DATADIR}/${PN}
+ doins ${WORKDIR}/{legacy.dat,doom1.wad}
+
+ dohtml _doc/*.html
+ rm _doc/*.html
+ dodoc _doc/*
+ prepgamesdirs
+}
diff --git a/games-fps/doomlegacy/files/1.41-errno.patch b/games-fps/doomlegacy/files/1.41-errno.patch
new file mode 100644
index 000000000000..c9aa3c6ffef0
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.41-errno.patch
@@ -0,0 +1,30 @@
+diff -ur legacy_141_src.orig/linux_x/i_video_xshm.c legacy_141_src/linux_x/i_video_xshm.c
+--- legacy_141_src.orig/linux_x/i_video_xshm.c 2003-10-11 00:28:13.262502728 -0400
++++ legacy_141_src/linux_x/i_video_xshm.c 2003-10-11 00:29:16.525885232 -0400
+@@ -1561,7 +1561,6 @@
+ id = shmget((key_t) key, size, IPC_CREAT | 0777);
+ if (id == -1)
+ {
+- extern int errno;
+ fprintf(stderr, "errno=%d\n", errno);
+ I_Error("Could not get any shared memory");
+ }
+diff -ur legacy_141_src.orig/linux_x/sndserv/linux.c legacy_141_src/linux_x/sndserv/linux.c
+--- legacy_141_src.orig/linux_x/sndserv/linux.c 2003-10-11 00:28:13.264502424 -0400
++++ legacy_141_src/linux_x/sndserv/linux.c 2003-10-11 00:28:40.480364984 -0400
+@@ -42,6 +42,7 @@
+ //
+ //-----------------------------------------------------------------------------
+
++#include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <fcntl.h>
+@@ -68,7 +69,6 @@
+ void myioctl(int fd, int command, int *arg)
+ {
+ int rc;
+- extern int errno;
+
+ rc = ioctl(fd, command, arg);
+ if (rc < 0)
diff --git a/games-fps/doomlegacy/files/1.41-makefile.patch b/games-fps/doomlegacy/files/1.41-makefile.patch
new file mode 100644
index 000000000000..c48890f4af15
--- /dev/null
+++ b/games-fps/doomlegacy/files/1.41-makefile.patch
@@ -0,0 +1,105 @@
+--- makefile.orig 2003-10-11 00:47:50.326561792 -0400
++++ makefile 2003-10-11 00:50:16.859285432 -0400
+@@ -533,11 +533,11 @@
+
+ ifndef SOLARIS
+ ifdef GCC30
+- M5=-march=pentium
+- M4=-march=486
++ M5=
++ M4=
+ else
+- M5=-mpentium
+- M4=-m486
++ M5=
++ M4=
+ endif
+ endif
+
+@@ -547,7 +547,7 @@
+ ifdef PGCC
+ CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
+ else
+- CFLAGS = -g -pg $(M4) -O3 -ffast-math -fwritable-strings $(OPTS)
++ CFLAGS = -g -pg $(M4) $(OPTS) $(EXTRAOPTS)
+ endif
+ LDFLAGS = -g -pg -L/usr/X11R6/lib
+ else
+@@ -555,13 +555,13 @@
+
+ # build a normal optimised version
+ ifdef PGCC
+- CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
++ CFLAGS = $(OPTS) $(M5) -fwritable-strings $(EXTRAOPTS)
+ # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
+ # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps \
+ # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
+ # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
+ else
+- CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
++ CFLAGS = $(M4) -fwritable-strings $(OPTS) $(EXTRAOPTS)
+ endif
+ endif
+
+@@ -735,7 +735,7 @@
+
+ #dll
+ dll : $(O)/r_opengl.o $(O)/ogl_x11.o
+- $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
++ $(CC) $(M5) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
+
+ musserv:
+ @mkdir -p $(MUSSERV)/linux
+@@ -749,7 +749,7 @@
+
+ ifdef LINUX
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif
+
+ ifdef SDL
+@@ -763,7 +763,7 @@
+ $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
+ else #FBSD_SDL
+ $(O)/r_opengl.o: hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++ $(CC) $(M5) -o $(O)/r_opengl.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif #FBSD_SDL
+ endif #FREEBSD
+
+@@ -774,10 +774,10 @@
+
+ ifndef FREEBSD
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ else
+ $(O)/ogl_x11.o: hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+- $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++ $(CC) $(M5) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ endif
+
+
+--- linux_x/musserv/Makefile.linux.orig 2003-10-11 00:51:31.193984840 -0400
++++ linux_x/musserv/Makefile.linux 2003-10-11 00:51:36.756139264 -0400
+@@ -3,7 +3,7 @@
+ #
+
+ CC = gcc
+-CFLAGS = -I. -Wall -O2 -m486
++CFLAGS = -I. -Wall $(EXTRAOPTS)
+ LDFLAGS =
+ #LDFLAGS = -static
+
+--- linux_x/sndserv/Makefile.orig 2003-10-11 00:50:41.640518112 -0400
++++ linux_x/sndserv/Makefile 2003-10-11 00:50:58.250992936 -0400
+@@ -30,7 +30,7 @@
+ #
+
+ CC=gcc
+-CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX
++CFLAGS=$(EXTRAOPTS) -Wall -DNORMALUNIX -DLINUX
+ ifdef FREEBSD
+ CFLAGS:=${CFLAGS} -DFREEBSD
+ endif
diff --git a/games-fps/doomlegacy/files/digest-doomlegacy-1.41 b/games-fps/doomlegacy/files/digest-doomlegacy-1.41
new file mode 100644
index 000000000000..d3f1adda6bea
--- /dev/null
+++ b/games-fps/doomlegacy/files/digest-doomlegacy-1.41
@@ -0,0 +1,3 @@
+MD5 4e64cb19e0e57055e664bdf09bce14d2 legacy_141_src.tar.gz 1600679
+MD5 4a3e88115c20f42d18e88f5666f8d4d6 legacy.dat.gz 334964
+MD5 66851d7cecbc7845d612e7073c1355ad doom1.wad.gz 1765820