summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2010-08-21 01:27:23 +0000
committerRichard Freeman <rich0@gentoo.org>2010-08-21 01:27:23 +0000
commitb5b004aa77a8b0f56fb8971a30d24cb8f17224b4 (patch)
tree85369c1dad9f71392e3ddc11fe724303da075cf6 /app-backup/sarab/sarab-1.0.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.tar.gz
gentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.tar.bz2
gentoo-2-b5b004aa77a8b0f56fb8971a30d24cb8f17224b4.zip
bump - 322817, thanks all for patience
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/sarab/sarab-1.0.0.ebuild')
-rw-r--r--app-backup/sarab/sarab-1.0.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/sarab/sarab-1.0.0.ebuild b/app-backup/sarab/sarab-1.0.0.ebuild
new file mode 100644
index 000000000000..aeab495faaee
--- /dev/null
+++ b/app-backup/sarab/sarab-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/sarab/sarab-1.0.0.ebuild,v 1.1 2010/08/21 01:27:23 rich0 Exp $
+
+inherit eutils
+
+DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR."
+HOMEPAGE="http://sarab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-backup/dar
+ virtual/mailx"
+
+src_unpack() {
+ cd "${S}"
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${PV}-better-defaults-gentoo.patch
+}
+
+src_install() {
+ dobin sarab.sh
+ insinto /etc/sarab
+ doins -r etc/*
+ # sarab.conf could contain passphrase information
+ fperms 600 /etc/sarab/sarab.conf
+ dodoc CHANGELOG FAQ INSTALL README
+ dodoc "${FILESDIR}"/README.Gentoo
+}
+
+pkg_postinstl() {
+ ewarn "The configuration format for DAR encryption has changed in Sarab 0.2.4."
+ ewarn "Replace DAR_ENCRYPTION_OPTIONS=\"--key blowfish:PASSPHRASE\""
+ ewarn "by SARAB_KEY=\"blowfish:PASSPHRASE\" in /etc/sarab/sarab.conf"
+}