summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-26 15:24:01 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-26 15:24:01 +0000
commitb5d31a891467a2d6fa0670d34e91b3cfedded44e (patch)
treea7e40c1340933ef6c41d0823c5455463bc3bb4e4 /app-crypt
parentadded to stable tree (diff)
downloadgentoo-2-b5d31a891467a2d6fa0670d34e91b3cfedded44e.tar.gz
gentoo-2-b5d31a891467a2d6fa0670d34e91b3cfedded44e.tar.bz2
gentoo-2-b5d31a891467a2d6fa0670d34e91b3cfedded44e.zip
Security update.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/ChangeLog7
-rw-r--r--app-crypt/heimdal/files/digest-heimdal-0.5.11
-rw-r--r--app-crypt/heimdal/heimdal-0.5.1.ebuild60
-rw-r--r--app-crypt/kth-krb/ChangeLog7
-rw-r--r--app-crypt/kth-krb/files/digest-kth-krb-1.2.11
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.1.ebuild54
6 files changed, 128 insertions, 2 deletions
diff --git a/app-crypt/heimdal/ChangeLog b/app-crypt/heimdal/ChangeLog
index b861f19e6f8d..37c44195cc91 100644
--- a/app-crypt/heimdal/ChangeLog
+++ b/app-crypt/heimdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/heimdal
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.3 2002/10/14 14:53:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/ChangeLog,v 1.4 2002/10/26 15:24:01 aliz Exp $
+
+*heimdal-0.5.1 (26 Oct 2002)
+
+ 26 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update. Found by Ian <ian@stacken.kth.se>.
*heimdal-0.5 (14 Oct 2002)
diff --git a/app-crypt/heimdal/files/digest-heimdal-0.5.1 b/app-crypt/heimdal/files/digest-heimdal-0.5.1
new file mode 100644
index 000000000000..1a8baebe1014
--- /dev/null
+++ b/app-crypt/heimdal/files/digest-heimdal-0.5.1
@@ -0,0 +1 @@
+MD5 bef2257673ddb9196702bf60c550ce53 heimdal-0.5.1.tar.gz 2979612
diff --git a/app-crypt/heimdal/heimdal-0.5.1.ebuild b/app-crypt/heimdal/heimdal-0.5.1.ebuild
new file mode 100644
index 000000000000..a103b4467290
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.5.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.5.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kerberos 5 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+IUSE="ssl ldap berkdb ipv6"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=app-crypt/kth-krb-1.2.1
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ berkdb? ( sys-libs/db )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/lib/krb5
+ mv Makefile.in Makefile.in.bak
+ sed "s:LIB_crypt = @LIB_crypt@:LIB_crypt = -lssl @LIB_crypt@:g" Makefile.in.bak >Makefile.in
+
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="--with-openssl=/usr" || myconf="--without-openssl"
+
+ use ldap && myconf="${myconf} --with-open-ldap=/usr"
+
+ use ipv6 || myconf="${myconf} --without-ipv6"
+
+ use berkdb || myconf="${myconf} --without-berkely-db"
+
+echo $myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/heimdal \
+ --sysconfdir=/etc \
+ --with-krb4=/usr/athena \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr/heimdal \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/01heimdal ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}
diff --git a/app-crypt/kth-krb/ChangeLog b/app-crypt/kth-krb/ChangeLog
index 0f7a60febc58..09dc891fe1e5 100644
--- a/app-crypt/kth-krb/ChangeLog
+++ b/app-crypt/kth-krb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/kth-krb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.4 2002/10/18 09:04:22 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.5 2002/10/26 15:24:01 aliz Exp $
+
+*kth-krb 1.2.1 (26 Oct 2002)
+
+ 26 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update. Found by Ian <ian@stacken.kth.se>.
*kth-krb 1.2 (18 Oct 2002)
diff --git a/app-crypt/kth-krb/files/digest-kth-krb-1.2.1 b/app-crypt/kth-krb/files/digest-kth-krb-1.2.1
new file mode 100644
index 000000000000..05b7f323df82
--- /dev/null
+++ b/app-crypt/kth-krb/files/digest-kth-krb-1.2.1
@@ -0,0 +1 @@
+MD5 0a18ef26ec7ab67082d43797ebd23a62 krb4-1.2.1.tar.gz 1876149
diff --git a/app-crypt/kth-krb/kth-krb-1.2.1.ebuild b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
new file mode 100644
index 000000000000..47e73c92a8dd
--- /dev/null
+++ b/app-crypt/kth-krb/kth-krb-1.2.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.1.ebuild,v 1.1 2002/10/26 15:24:01 aliz Exp $
+
+IUSE="ssl afs"
+
+S=${WORKDIR}/krb4-${PV}
+DESCRIPTION="Kerberos 4 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ afs? ( >=net-fs/openafs-1.2.2-r7 )"
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl=/usr"
+
+ use afs || myconf="${myconf} --without-afs-support"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/athena \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr/athena \
+ sysconfdir=${D}/etc \
+ install || die
+
+ # Doesn't get install otherwise (for some reason, look into this).
+ if [ "`use ssl`" ] ; then
+ cd ${S}/lib/des
+
+ make prefix=${D}/usr/athena \
+ install || die
+
+ cd ${S}
+ fi
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/02kth-krb ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}