summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-10-25 17:36:07 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-10-25 17:36:07 +0000
commit3800a7eab17becb1b732a5f02e6e6a855efd9d80 (patch)
treec7c6f1afd96a24fa306607d5004068a1827e15e8 /app-editors/nedit/files
parentRemove welp from metadata.xml (#141007) (diff)
downloadgentoo-2-3800a7eab17becb1b732a5f02e6e6a855efd9d80.tar.gz
gentoo-2-3800a7eab17becb1b732a5f02e6e6a855efd9d80.tar.bz2
gentoo-2-3800a7eab17becb1b732a5f02e6e6a855efd9d80.zip
Respecting LDFLAGS, patch thanks to Justin Lecher <jlec@j-schmitz.net> bug 290337
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-editors/nedit/files')
-rw-r--r--app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch b/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch
new file mode 100644
index 000000000000..4532c6251894
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.5_p20090914-ldflags.patch
@@ -0,0 +1,17 @@
+--- source/Makefile.common 2004-03-21 15:25:56.000000000 +0100
++++ source/Makefile.common.new 2009-10-24 10:47:03.667835157 +0200
+@@ -21,12 +21,12 @@
+ # we only want natural rebuilds to regenerate the link date.
+ nedit: $(OBJS) ../util/libNUtil.a $(XMLLIB) $(XLTLIB)
+ $(CC) $(CFLAGS) -c linkdate.c
+- $(CC) $(CFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
+ $(XLTLIB) ../util/libNUtil.a $(LIBS) -o $@
+
+ # Note LIBS isn't quite right here; it links unnecessarily against Motif
+ nc: nc.o server_common.o ../util/libNUtil.a
+- $(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+
+ help.o: help.c
+ $(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@