summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 15:20:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 15:20:19 +0000
commitce7c28a39577fede0b05995255cf25a2a4ba7a4c (patch)
tree684d64f47cc6a1f4d12b07bbb9935d32ed2c36d2 /app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
parentalpha/ia64/sparc stable wrt #333717 (diff)
downloadgentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.tar.gz
gentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.tar.bz2
gentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.zip
Respecting LDFLAGS, 337878
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild')
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..a82ec0d41645
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild,v 1.1 2010/09/18 15:20:19 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ tc-export CC
+}
+
+#src_compile() {
+# emake -C src CCOPTS="${CFLAGS}" || die "emake failed"
+#}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
+ dosym iso3166 /usr/bin/countrycodes || die
+ dosym iso3166.1 /usr/share/man/man1/countrycodes || die
+ dodoc ../doc/{Changelog,README} || die
+ prepman
+}