summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-09-11 16:30:54 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-09-11 16:30:54 +0000
commitc127f45b114570f9fdc6a382fd92d58ca0936d39 (patch)
tree6b1e243ff10d9b55cc3beb528a44fe70bd613bce /dev-db/mysql/mysql-4.0.25-r2.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.tar.gz
gentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.tar.bz2
gentoo-2-c127f45b114570f9fdc6a382fd92d58ca0936d39.zip
Hidding passwords when requested in pkg_config().
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-db/mysql/mysql-4.0.25-r2.ebuild')
-rw-r--r--dev-db/mysql/mysql-4.0.25-r2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-db/mysql/mysql-4.0.25-r2.ebuild b/dev-db/mysql/mysql-4.0.25-r2.ebuild
index feefabe20b92..d012b94bebac 100644
--- a/dev-db/mysql/mysql-4.0.25-r2.ebuild
+++ b/dev-db/mysql/mysql-4.0.25-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.14 2005/09/10 08:52:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.15 2005/09/11 16:30:54 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -366,13 +366,13 @@ pkg_config() {
einfo "permissions on it..."
einfo "Insert a password for the mysql 'root' user"
- ewarn "the password will be visible on the screen"
+ ewarn "bug: avoid [\"'\\_%] characters in the password"
- echo -n " >" && read -r pwd1
- einfo "Repeat the password"
- echo -n " >" && read -r pwd2
+ read -rsp " >" pwd1 ; echo
+ einfo "Check the password"
+ read -rsp " >" pwd2 ; echo
- if (( "x$pwd1" != "x$pwd2" )) ; then
+ if [[ "x$pwd1" != "x$pwd2" ]] ; then
die "Passwords are not the same"
fi