summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2013-04-04 16:18:50 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2013-04-04 16:18:50 +0000
commit4f7f2547ae4763e9b920d9158df560a5dbe3393a (patch)
tree54e98bca7a98206be422a4984f1baaaa70cce8d5 /dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild
parentDrop unnecessary usage of autotools-utils and add support for (diff)
downloadgentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.tar.gz
gentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.tar.bz2
gentoo-2-4f7f2547ae4763e9b920d9158df560a5dbe3393a.zip
Security bump. Bug 463884.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild')
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild
new file mode 100644
index 000000000000..4eb2452ccbb7
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.4.17.ebuild,v 1.1 2013/04/04 16:18:49 titanofold Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ dodir ${mypath}/html
+ tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}