summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 12:37:26 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 12:37:26 +0000
commitd3820eba8877e01eee811c90fba9999aa58b547b (patch)
tree264e1cb2a3231d5c005fcdb1f256bef3d03a635c /dev-haskell/crypto-conduit
parentunmask flac-1.3, bug #472950 (diff)
downloadgentoo-2-d3820eba8877e01eee811c90fba9999aa58b547b.tar.gz
gentoo-2-d3820eba8877e01eee811c90fba9999aa58b547b.tar.bz2
gentoo-2-d3820eba8877e01eee811c90fba9999aa58b547b.zip
Bump crypto-conduit to 0.5.2.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/crypto-conduit')
-rw-r--r--dev-haskell/crypto-conduit/ChangeLog9
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-haskell/crypto-conduit/ChangeLog b/dev-haskell/crypto-conduit/ChangeLog
index 2e6d9e3c2826..4f1d33c6c98d 100644
--- a/dev-haskell/crypto-conduit/ChangeLog
+++ b/dev-haskell/crypto-conduit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/crypto-conduit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/ChangeLog,v 1.2 2013/12/11 05:52:16 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/ChangeLog,v 1.3 2014/03/09 12:37:26 gienah Exp $
+
+*crypto-conduit-0.5.2.2 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +crypto-conduit-0.5.2.2.ebuild:
+ Bump crypto-conduit to 0.5.2.2
*crypto-conduit-0.5.2.1 (11 Dec 2013)
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild
new file mode 100644
index 000000000000..7b48a688bc9a
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-conduit/crypto-conduit-0.5.2.2.ebuild,v 1.1 2014/03/09 12:37:26 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)."
+HOMEPAGE="https://github.com/meteficha/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.5:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-old-crypto-api
+}