summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2013-08-18 03:12:49 +0000
committerStephen Klimaszewski <steev@gentoo.org>2013-08-18 03:12:49 +0000
commite1e015352c889db7a581a6c810920a390dca3bac (patch)
treef790009fe6328bac1eacc766c9a05263212bbf06 /dev-lang/v8
parentWhitespace (diff)
downloadgentoo-2-e1e015352c889db7a581a6c810920a390dca3bac.tar.gz
gentoo-2-e1e015352c889db7a581a6c810920a390dca3bac.tar.bz2
gentoo-2-e1e015352c889db7a581a6c810920a390dca3bac.zip
v8: Add default to arm_fpu so that build doesn't fail when mfpu=(anything but neon)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-3.18.5.14.ebuild4
-rw-r--r--dev-lang/v8/v8-3.19.18.18.ebuild4
-rw-r--r--dev-lang/v8/v8-3.19.18.19.ebuild4
-rw-r--r--dev-lang/v8/v8-3.20.12.1.ebuild4
-rw-r--r--dev-lang/v8/v8-3.20.15.5.ebuild4
-rw-r--r--dev-lang/v8/v8-9999.ebuild4
7 files changed, 19 insertions, 13 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 95f0b466ded5..67144455d814 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.334 2013/08/18 03:01:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.335 2013/08/18 03:12:49 steev Exp $
+
+ 18 Aug 2013; Steev Klimaszewski <steev@gentoo.org> v8-3.18.5.14.ebuild,
+ v8-3.19.18.18.ebuild, v8-3.19.18.19.ebuild, v8-3.20.12.1.ebuild,
+ v8-3.20.15.5.ebuild, v8-9999.ebuild:
+ v8: Add default to arm_fpu so that build doesn't fail when mfpu=(anything but
+ neon)
*v8-3.19.18.19 (18 Aug 2013)
diff --git a/dev-lang/v8/v8-3.18.5.14.ebuild b/dev-lang/v8/v8-3.18.5.14.ebuild
index 72add4629ae0..743bfd8c9168 100644
--- a/dev-lang/v8/v8-3.18.5.14.ebuild
+++ b/dev-lang/v8/v8-3.18.5.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.18.5.14.ebuild,v 1.3 2013/07/31 08:47:17 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.18.5.14.ebuild,v 1.4 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -46,7 +46,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else
diff --git a/dev-lang/v8/v8-3.19.18.18.ebuild b/dev-lang/v8/v8-3.19.18.18.ebuild
index bfbf5a64574b..ddd0cc98468b 100644
--- a/dev-lang/v8/v8-3.19.18.18.ebuild
+++ b/dev-lang/v8/v8-3.19.18.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.19.18.18.ebuild,v 1.1 2013/08/09 03:44:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.19.18.18.ebuild,v 1.2 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -46,7 +46,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else
diff --git a/dev-lang/v8/v8-3.19.18.19.ebuild b/dev-lang/v8/v8-3.19.18.19.ebuild
index 98548d4eee38..607bcf140385 100644
--- a/dev-lang/v8/v8-3.19.18.19.ebuild
+++ b/dev-lang/v8/v8-3.19.18.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.19.18.19.ebuild,v 1.1 2013/08/18 03:01:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.19.18.19.ebuild,v 1.2 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -46,7 +46,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else
diff --git a/dev-lang/v8/v8-3.20.12.1.ebuild b/dev-lang/v8/v8-3.20.12.1.ebuild
index 81af7fa81a05..c81083eabeae 100644
--- a/dev-lang/v8/v8-3.20.12.1.ebuild
+++ b/dev-lang/v8/v8-3.20.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.20.12.1.ebuild,v 1.1 2013/08/13 03:56:22 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.20.12.1.ebuild,v 1.2 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -52,7 +52,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else
diff --git a/dev-lang/v8/v8-3.20.15.5.ebuild b/dev-lang/v8/v8-3.20.15.5.ebuild
index 1d31a99ced97..7fe9f201e46a 100644
--- a/dev-lang/v8/v8-3.20.15.5.ebuild
+++ b/dev-lang/v8/v8-3.20.15.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.20.15.5.ebuild,v 1.1 2013/08/17 22:41:58 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.20.15.5.ebuild,v 1.2 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -52,7 +52,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 6ac2f2d86e3f..cc6119371517 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.47 2013/07/31 04:34:22 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.48 2013/08/18 03:12:49 steev Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -60,7 +60,7 @@ src_configure() {
fi ;;
arm*-*)
myarch="arm"
- myconf+=" -Dv8_target_arch=arm -Darm_fpu="
+ myconf+=" -Dv8_target_arch=arm -Darm_fpu=default"
if [[ ${CHOST} == *-hardfloat-* ]] ; then
myconf+=" -Dv8_use_arm_eabi_hardfloat=true"
else