summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2007-05-08 14:42:26 +0000
committerBryan Østergaard <kloeri@gentoo.org>2007-05-08 14:42:26 +0000
commit249e67177ef3f81d2bce760924eeb1d95b789686 (patch)
tree98a4dc3b117123f87c2d22f2cd021af41b1ec339 /dev-lang
parentia64 stable wrt #169591 (diff)
downloadgentoo-2-249e67177ef3f81d2bce760924eeb1d95b789686.tar.gz
gentoo-2-249e67177ef3f81d2bce760924eeb1d95b789686.tar.bz2
gentoo-2-249e67177ef3f81d2bce760924eeb1d95b789686.zip
Change nptl USE flag to threads.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.3.6-r1.ebuild6
-rw-r--r--dev-lang/python/python-2.4.4-r2.ebuild6
-rw-r--r--dev-lang/python/python-2.5.1.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index cf6730822096..cc85d4d1b2ec 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.235 2007/05/08 03:01:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.236 2007/05/08 14:42:26 kloeri Exp $
+
+ 08 May 2007; Bryan Østergaard <kloeri@gentoo.org> python-2.3.6-r1.ebuild,
+ python-2.4.4-r2.ebuild, python-2.5.1.ebuild:
+ Change nptl USE flag to threads.
08 May 2007; Jeroen Roovers <jer@gentoo.org> python-2.5.1.ebuild:
Marked ~hppa (bug #177426).
diff --git a/dev-lang/python/python-2.3.6-r1.ebuild b/dev-lang/python/python-2.3.6-r1.ebuild
index afd71836355f..740cad569da9 100644
--- a/dev-lang/python/python-2.3.6-r1.ebuild
+++ b/dev-lang/python/python-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.6-r1.ebuild,v 1.5 2007/05/07 19:17:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.6-r1.ebuild,v 1.6 2007/05/08 14:42:26 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -22,7 +22,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${PV}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.3"
KEYWORDS="~hppa ~x86"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nptl examples"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx threads examples"
# INFO: 2.3.5 docs are used for python-2.3.6 as upstream writes in their release
# notes.
@@ -135,7 +135,7 @@ src_compile() {
`use_enable ipv6` \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
- `use_with nptl threads` \
+ `use_with threads` \
--with-libc='' \
${myconf} || die
emake || die "Parallel make failed"
diff --git a/dev-lang/python/python-2.4.4-r2.ebuild b/dev-lang/python/python-2.4.4-r2.ebuild
index a032230d637c..d2723a5ff968 100644
--- a/dev-lang/python/python-2.4.4-r2.ebuild
+++ b/dev-lang/python/python-2.4.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r2.ebuild,v 1.2 2007/05/07 19:25:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.4-r2.ebuild,v 1.3 2007/05/08 14:42:26 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="~hppa ~x86"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx nptl examples"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 doc nocxx threads examples"
DEPEND=">=sys-libs/zlib-1.1.3
!dev-python/cjkcodecs
@@ -154,7 +154,7 @@ src_compile() {
`use_enable ipv6` \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
- `use_with nptl threads` \
+ `use_with threads` \
--with-libc='' \
${myconf} || die
emake || die "Parallel make failed"
diff --git a/dev-lang/python/python-2.5.1.ebuild b/dev-lang/python/python-2.5.1.ebuild
index 485e9136a801..61c020b3de66 100644
--- a/dev-lang/python/python-2.5.1.ebuild
+++ b/dev-lang/python/python-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.1.ebuild,v 1.2 2007/05/08 03:01:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.1.ebuild,v 1.3 2007/05/08 14:42:26 kloeri Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -25,7 +25,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
KEYWORDS="~hppa ~x86"
-IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 sqlite doc nocxx nptl examples"
+IUSE="ncurses gdbm ssl readline tk berkdb bootstrap ipv6 build ucs2 sqlite doc nocxx threads examples"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes,cjkcodecs}
# do not conflict with the ones in python proper. - liquidx
@@ -162,7 +162,7 @@ src_compile() {
`use_enable ipv6` \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
- `use_with nptl threads` \
+ `use_with threads` \
--with-libc='' \
${myconf} || die
emake || die "Parallel make failed"