summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-05 13:12:30 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-05 13:12:30 +0000
commita31288501f37e759642b8c9b06fec5883f6baaef (patch)
treec07c86bededc2b3b31a38ad17724321d0e24857c /dev-libs/glib/files
parentMarked ~ppc wrt #369595 (diff)
downloadgentoo-2-a31288501f37e759642b8c9b06fec5883f6baaef.tar.gz
gentoo-2-a31288501f37e759642b8c9b06fec5883f6baaef.tar.bz2
gentoo-2-a31288501f37e759642b8c9b06fec5883f6baaef.zip
Block broken gtk-doc versions that causes problems like bug #363213. Remove old. Make repoman happier with glib-1.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/glib/files')
-rw-r--r--dev-libs/glib/files/glib-2.24-punt-python-check.patch20
-rw-r--r--dev-libs/glib/files/glib-2.26.1-gsettings-read.patch25
-rw-r--r--dev-libs/glib/files/glib-2.26.1-locked-message.patch68
3 files changed, 0 insertions, 113 deletions
diff --git a/dev-libs/glib/files/glib-2.24-punt-python-check.patch b/dev-libs/glib/files/glib-2.24-punt-python-check.patch
deleted file mode 100644
index 3cbd6dc15155..000000000000
--- a/dev-libs/glib/files/glib-2.24-punt-python-check.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Remove python detection from configure.in, we won't be installing the gdb python
-scripts anymore. They use a redhat-specific gdb module that has not been
-upstreamed yet.
-
-https://bugs.gentoo.org/291328
-https://bugzilla.gnome.org/623552
----
---- configure.in
-+++ configure.in
-@@ -379,10 +379,6 @@ if test "x$PERL_PATH" = x ; then
- fi
- AC_SUBST(PERL_PATH)
-
--# Need suitable python path for greport
--AM_PATH_PYTHON(2.4,,PYTHON="/usr/bin/env python2.4")
--
--
- dnl ***********************
- dnl *** Tests for iconv ***
- dnl ***********************
diff --git a/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch b/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch
deleted file mode 100644
index fa5b081bcc36..000000000000
--- a/dev-libs/glib/files/glib-2.26.1-gsettings-read.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 900a4c853f8dbf0887c66155ba489ff4570e5948 Mon Sep 17 00:00:00 2001
-From: Matthew Barnes <mbarnes@redhat.com>
-Date: Wed, 01 Dec 2010 00:19:12 +0000
-Subject: Bug 636100 - Can't read GSettings:backend property
-
-The PROP_BACKEND case was missing from the switch statement in
-g_settings_get_property().
----
-diff --git a/gio/gsettings.c b/gio/gsettings.c
-index 94d1f3a..7f775a0 100644
---- a/gio/gsettings.c
-+++ b/gio/gsettings.c
-@@ -417,6 +417,10 @@ g_settings_get_property (GObject *object,
- g_value_set_string (value, settings->priv->schema_name);
- break;
-
-+ case PROP_BACKEND:
-+ g_value_set_object (value, settings->priv->backend);
-+ break;
-+
- case PROP_PATH:
- g_value_set_string (value, settings->priv->path);
- break;
---
-cgit v0.8.3.1
diff --git a/dev-libs/glib/files/glib-2.26.1-locked-message.patch b/dev-libs/glib/files/glib-2.26.1-locked-message.patch
deleted file mode 100644
index acec46e5daf8..000000000000
--- a/dev-libs/glib/files/glib-2.26.1-locked-message.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 62476cd0f7ca7d3becf81243fb7ac1b97cf7db51 Mon Sep 17 00:00:00 2001
-From: Peng Huang <shawn.p.huang@gmail.com>
-Date: Mon, 13 Dec 2010 18:09:38 +0000
-Subject: Bug 632544 – Cannot send a locked message with PRESERVE_SERIAL flag
-
-https://bugzilla.gnome.org/show_bug.cgi?id=632544
-
-Signed-off-by: David Zeuthen <davidz@redhat.com>
----
-diff --git a/gio/gdbusconnection.c b/gio/gdbusconnection.c
-index da2b9f9..cf12f41 100644
---- a/gio/gdbusconnection.c
-+++ b/gio/gdbusconnection.c
-@@ -1449,7 +1449,8 @@ g_dbus_connection_send_message_unlocked (GDBusConnection *connection,
- if (out_serial != NULL)
- *out_serial = serial_to_use;
-
-- g_dbus_message_set_serial (message, serial_to_use);
-+ if (!(flags & G_DBUS_SEND_MESSAGE_FLAGS_PRESERVE_SERIAL))
-+ g_dbus_message_set_serial (message, serial_to_use);
-
- g_dbus_message_lock (message);
- _g_dbus_worker_send_message (connection->worker,
-diff --git a/gio/tests/gdbus-connection.c b/gio/tests/gdbus-connection.c
-index 866e27c..5c2939e 100644
---- a/gio/tests/gdbus-connection.c
-+++ b/gio/tests/gdbus-connection.c
-@@ -880,6 +880,18 @@ test_connection_filter (void)
-
- m2 = g_dbus_message_copy (m, &error);
- g_assert_no_error (error);
-+ g_dbus_message_set_serial (m2, data.serial);
-+ /* lock the message to test PRESERVE_SERIAL flag. */
-+ g_dbus_message_lock (m2);
-+ g_dbus_connection_send_message (c, m2, G_DBUS_SEND_MESSAGE_FLAGS_PRESERVE_SERIAL, &data.serial, &error);
-+ g_object_unref (m2);
-+ g_assert_no_error (error);
-+
-+ while (data.num_handled == 2)
-+ g_thread_yield ();
-+
-+ m2 = g_dbus_message_copy (m, &error);
-+ g_assert_no_error (error);
- r = g_dbus_connection_send_message_with_reply_sync (c,
- m2,
- G_DBUS_SEND_MESSAGE_FLAGS_NONE,
-@@ -891,7 +903,7 @@ test_connection_filter (void)
- g_assert_no_error (error);
- g_assert (r != NULL);
- g_object_unref (r);
-- g_assert_cmpint (data.num_handled, ==, 3);
-+ g_assert_cmpint (data.num_handled, ==, 4);
-
- g_dbus_connection_remove_filter (c, filter_id);
-
-@@ -908,8 +920,8 @@ test_connection_filter (void)
- g_assert_no_error (error);
- g_assert (r != NULL);
- g_object_unref (r);
-- g_assert_cmpint (data.num_handled, ==, 3);
-- g_assert_cmpint (data.num_outgoing, ==, 3);
-+ g_assert_cmpint (data.num_handled, ==, 4);
-+ g_assert_cmpint (data.num_outgoing, ==, 4);
-
- /* this is safe; testserver will exit once the bus goes away */
- g_assert (g_spawn_command_line_async (SRCDIR "/gdbus-testserver.py", NULL));
---
-cgit v0.8.3.1