summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-07 06:51:28 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-07 06:51:28 +0000
commitfbb118555c8a084c85a8a1acba0840c4d12f3102 (patch)
tree3e1e13d1f72c1f473a8e24a114e4c3056b2d7917 /dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild
parentAdd github homepage. (diff)
downloadgentoo-2-fbb118555c8a084c85a8a1acba0840c4d12f3102.tar.gz
gentoo-2-fbb118555c8a084c85a8a1acba0840c4d12f3102.tar.bz2
gentoo-2-fbb118555c8a084c85a8a1acba0840c4d12f3102.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild b/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild
new file mode 100644
index 000000000000..c85170e184ad
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/protobuf-c-1.0.2.ebuild,v 1.1 2014/10/07 06:51:28 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="code generator and runtime libraries to use Protocol Buffers (protobuf) from pure C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/protobuf-2.5.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}