summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-16 04:45:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-16 04:45:27 +0000
commit510fb60ab6fd0efbc614fb09ef33eac6d377146b (patch)
tree3245175da3db534b8e35f053150690e233865e81 /dev-python/cheetah
parentFixed building with tk-8.5 and glibc-2.10 (fixes bug #283265). (diff)
downloadgentoo-2-510fb60ab6fd0efbc614fb09ef33eac6d377146b.tar.gz
gentoo-2-510fb60ab6fd0efbc614fb09ef33eac6d377146b.tar.bz2
gentoo-2-510fb60ab6fd0efbc614fb09ef33eac6d377146b.zip
Version bump (bug #271379). Set SUPPORT_PYTHON_ABIS.
(Portage version: 14274-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/ChangeLog8
-rw-r--r--dev-python/cheetah/cheetah-2.2.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/cheetah/ChangeLog b/dev-python/cheetah/ChangeLog
index 4642ca81cbb4..e273cc89c305 100644
--- a/dev-python/cheetah/ChangeLog
+++ b/dev-python/cheetah/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/cheetah
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.46 2009/09/06 22:58:02 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.47 2009/09/16 04:45:27 arfrever Exp $
+
+*cheetah-2.2.2 (16 Sep 2009)
+
+ 16 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cheetah-2.2.2.ebuild:
+ Version bump (bug #271379). Set SUPPORT_PYTHON_ABIS.
06 Sep 2009; Christian Ruppert <idl0r@gentoo.org>
-files/Cheetah-0.9.18__future__imports.patch:
diff --git a/dev-python/cheetah/cheetah-2.2.2.ebuild b/dev-python/cheetah/cheetah-2.2.2.ebuild
new file mode 100644
index 000000000000..6cf1e02e34d6
--- /dev/null
+++ b/dev-python/cheetah/cheetah-2.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-2.2.2.ebuild,v 1.1 2009/09/16 04:45:27 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="Cheetah"
+MY_P="${MY_PN}-${PV/_}"
+
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/ http://rtyler.github.com/cheetah/"
+SRC_URI="http://pypi.python.org/packages/source/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/markdown"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Cheetah"
+DOCS="CHANGES README TODO"
+
+src_test() {
+ # Disable broken tests.
+ sed \
+ -e "/Unicode/d" \
+ -e "s/if not sys.platform.startswith('java'):/if False:/" \
+ -i cheetah/Tests/Test.py || die "sed failed"
+
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" cheetah/Tests/Test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ rm -fr "${D}"usr/lib*/python*/site-packages/Cheetah/Tests
+}