summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-08-23 07:52:52 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-08-23 07:52:52 +0000
commit26c375f51d3e4bd6083c4e439a8d2184c663625f (patch)
tree5c97f9b43e7f634c057232f09e075106074b6162 /dev-python/docutils/files
parentFix decoding error with Python 3.1 (bug 333361). (diff)
downloadgentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.tar.gz
gentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.tar.bz2
gentoo-2-26c375f51d3e4bd6083c4e439a8d2184c663625f.zip
Clean out old cruft.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/docutils/files')
-rw-r--r--dev-python/docutils/files/docutils-0.3.7-extramodules.patch32
-rw-r--r--dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch13
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/docutils/files/docutils-0.3.7-extramodules.patch b/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
deleted file mode 100644
index f5701d681cbe..000000000000
--- a/dev-python/docutils/files/docutils-0.3.7-extramodules.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- docutils-0.3.7/setup.py 2004-07-29 16:57:28.000000000 +0200
-+++ docutils-0.3.7/setup.py.new 2004-09-23 10:06:06.263010624 +0200
-@@ -82,20 +82,15 @@
- List of (module name, minimum __version__ string, [attribute names])."""
-
- def get_extras():
-- extras = []
-- for module_name, version, attributes in extra_modules:
-- try:
-- module = __import__(module_name)
-- if version and module.__version__ < version:
-- raise ValueError
-- for attribute in attributes or []:
-- getattr(module, attribute)
-- print ('"%s" module already present; ignoring extras/%s.py.'
-- % (module_name, module_name))
-- except (ImportError, AttributeError, ValueError):
-- extras.append(module_name)
-- return extras
--
-+ # old method does not work for upgrading/downgrading docutils.
-+ # so we use a simple rule, 'optparse' and 'textwrap' are not installed
-+ # for >=python-2.3
-+
-+ pyver = sys.version_info
-+ if pyver[0] == 2 and pyver[1] > 2:
-+ return ["roman"]
-+ else:
-+ return ["optparse","textwrap","roman"]
-
- class dual_build_py(build_py):
-
diff --git a/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch b/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch
deleted file mode 100644
index b55e392def58..000000000000
--- a/dev-python/docutils/files/docutils-0.5-test_node_class_names-python-2.6.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://svn.berlios.de/viewcvs/docutils?view=rev&revision=5599
-
---- trunk/docutils/test/test_nodes.py
-+++ trunk/docutils/test/test_nodes.py
-@@ -175,7 +175,7 @@
- node_class_names = []
- for x in dir(nodes):
- c = getattr(nodes, x)
-- if isinstance(c, ClassType) and issubclass(c, nodes.Node) \
-+ if isinstance(c, (type, ClassType)) and issubclass(c, nodes.Node) \
- and len(c.__bases__) > 1:
- node_class_names.append(x)
- node_class_names.sort()