summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-06-20 17:53:37 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-06-20 17:53:37 +0000
commitd1bd026520dc937668cb8e67a66afdd8c2d9c9ec (patch)
tree49d1d6947d98c0c1472ae19796c3d3952e00bbb7 /dev-python/pygame/pygame-1.7.1-r1.ebuild
parentFix my email address (diff)
downloadgentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.tar.gz
gentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.tar.bz2
gentoo-2-d1bd026520dc937668cb8e67a66afdd8c2d9c9ec.zip
Fix bug with python 2.5 and amd64, bug #194932. Remove old rc.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25-gentoo-r3 x86_64)
Diffstat (limited to 'dev-python/pygame/pygame-1.7.1-r1.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.7.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.7.1-r1.ebuild b/dev-python/pygame/pygame-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..4e08f65190bf
--- /dev/null
+++ b/dev-python/pygame/pygame-1.7.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1-r1.ebuild,v 1.1 2008/06/20 17:53:36 coldwind Exp $
+
+inherit eutils distutils
+
+MY_P="${P}release"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
+HOMEPAGE="http://www.pygame.org/"
+SRC_URI="http://www.pygame.org/ftp/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="virtual/python
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.4
+ >=dev-python/numeric-22.0
+ >=media-libs/smpeg-0.4.4-r1"
+
+src_unpack() {
+ unpack ${A}
+ # Search correct libdir for existing sdl libs
+ sed -i -e "s:/lib:/$(get_libdir):" ${S}/config_unix.py || die
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python2.5.patch
+}
+
+src_install() {
+ DOCS=WHATSNEW
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/*
+ insinto /usr/share/doc/${PF}/examples
+ doins ${S}/examples/*
+ insinto /usr/share/doc/${PF}/examples/data
+ doins ${S}/examples/data/*
+ fi
+}