summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-11-18 16:05:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-11-18 16:05:15 +0000
commit0c64a73c276cbf8bee2684c2212c3357bdbf6558 (patch)
tree35f0dc4e50187b72fc8bf2fefd6d947c9b9167cd /games-arcade
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Elij... (diff)
downloadgentoo-2-0c64a73c276cbf8bee2684c2212c3357bdbf6558.tar.gz
gentoo-2-0c64a73c276cbf8bee2684c2212c3357bdbf6558.tar.bz2
gentoo-2-0c64a73c276cbf8bee2684c2212c3357bdbf6558.zip
Initial commit - ebuild by ssuominen with style changes
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blobby/ChangeLog10
-rw-r--r--games-arcade/blobby/blobby-0.9c.ebuild47
-rw-r--r--games-arcade/blobby/metadata.xml5
3 files changed, 62 insertions, 0 deletions
diff --git a/games-arcade/blobby/ChangeLog b/games-arcade/blobby/ChangeLog
new file mode 100644
index 000000000000..a84fd61e5114
--- /dev/null
+++ b/games-arcade/blobby/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/blobby
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/ChangeLog,v 1.1 2011/11/18 16:05:15 mr_bones_ Exp $
+
+*blobby-0.9c (18 Nov 2011)
+
+ 18 Nov 2011; Michael Sterrett <mr_bones_@gentoo.org> +blobby-0.9c.ebuild,
+ +metadata.xml:
+ Initial commit - ebuild by ssuominen with style changes
+
diff --git a/games-arcade/blobby/blobby-0.9c.ebuild b/games-arcade/blobby/blobby-0.9c.ebuild
new file mode 100644
index 000000000000..f8221667ff0b
--- /dev/null
+++ b/games-arcade/blobby/blobby-0.9c.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/blobby-0.9c.ebuild,v 1.1 2011/11/18 16:05:15 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils games
+
+DESCRIPTION="A beach ball game with blobs of goo"
+HOMEPAGE="http://sourceforge.net/projects/blobby/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-linux-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-games/physfs-2[zip]
+ media-libs/libsdl[audio,joystick,opengl,video,X]
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-beta-${PV}
+
+src_prepare() {
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR}/${PN}:" data/CMakeLists.txt || die
+ sed -i -e "s:share/${PN}:${GAMES_DATADIR/\/usr\/}/${PN}:" src/main.cpp || die
+ sed -i -e "/DESTINATION/s:bin:${GAMES_BINDIR}:" src/CMakeLists.txt || die
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README TODO" cmake-utils_src_install
+
+ newicon data/Icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} "Blobby Volley" /usr/share/pixmaps/${PN}.bmp
+
+ prepgamesdirs
+}
diff --git a/games-arcade/blobby/metadata.xml b/games-arcade/blobby/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/blobby/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>