summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-12 21:47:41 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-12 21:47:41 +0000
commitb171eb2de4eb565c23c5711d99b4c3dfa99cc78b (patch)
treea2a8ed1cf753f2ca9d6bb0a2413e645a4b29a1a4 /games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
parentAdd ~sparc-fbsd keyword. (diff)
downloadgentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.tar.gz
gentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.tar.bz2
gentoo-2-b171eb2de4eb565c23c5711d99b4c3dfa99cc78b.zip
Version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild')
-rw-r--r--games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
new file mode 100644
index 000000000000..03ad6f9c5bbe
--- /dev/null
+++ b/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/dangerdeep/dangerdeep-0.3.0.ebuild,v 1.1 2007/06/12 21:47:41 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="a World War II German submarine simulation"
+HOMEPAGE="http://www.dangerdeep.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${PN}-data-${PV}.zip"
+
+LICENSE="GPL-2 CCPL-Attribution-NonCommercial-NoDerivs-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse debug"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ sci-libs/fftw
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ media-libs/sdl-net"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/scons"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+ sed -i \
+ -e "/console_log.txt/ s:fopen.*:stderr;:" \
+ src/system.cpp \
+ || die "sed failed"
+}
+
+src_compile() {
+ local sse=-1
+
+ if use sse ; then
+ use amd64 && sse=3 || sse=1
+ fi
+
+ scons \
+ usex86sse=${sse} \
+ datadir="${GAMES_DATADIR}"/${PN} \
+ $(use debug && echo debug=1) \
+ || die "scons failed"
+}
+
+src_install() {
+ dogamesbin build/linux/${PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r ../data/* || die "doins failed"
+
+ newicon logo.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Danger from the Deep" ${PN}.xpm
+
+ dodoc ChangeLog CREDITS README
+ doman doc/man/${PN}.6
+
+ prepgamesdirs
+}