summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:20:21 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-05-03 20:20:21 +0000
commit6f439f0c9e2b64acbbe5b1949a43675103221fed (patch)
tree3aefafc59276fb3cde3b997fddfcfd62ee73c04c /kde-base/kate
parentVersion bump KDE 4.4.3 (diff)
downloadgentoo-2-6f439f0c9e2b64acbbe5b1949a43675103221fed.tar.gz
gentoo-2-6f439f0c9e2b64acbbe5b1949a43675103221fed.tar.bz2
gentoo-2-6f439f0c9e2b64acbbe5b1949a43675103221fed.zip
Version bump KDE 4.4.3
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.4.3.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 79827f179d48..7f6fcb36a1b8 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.171 2010/03/31 22:06:12 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.172 2010/05/03 20:20:21 alexxy Exp $
+
+*kate-4.4.3 (03 May 2010)
+
+ 03 May 2010; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.4.3.ebuild:
+ Version bump
31 Mar 2010; Dror Levin <spatz@gentoo.org> -kate-4.3.4.ebuild,
-kate-4.4.0.ebuild:
diff --git a/kde-base/kate/kate-4.4.3.ebuild b/kde-base/kate/kate-4.4.3.ebuild
new file mode 100644
index 000000000000..f88b8a8f4ca1
--- /dev/null
+++ b/kde-base/kate/kate-4.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.4.3.ebuild,v 1.1 2010/05/03 20:20:21 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}