summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-24 17:13:48 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-24 17:13:48 +0000
commit8eeee40951b03de5b543d15fbf0f419f1a7aff2f (patch)
treeab78da00ab148f37404f3ae14cc3ec071a75e0b9 /media-libs/gluon/gluon-0.71.0.ebuild
parentUpdate USE descriptions. (diff)
downloadgentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.tar.gz
gentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.tar.bz2
gentoo-2-8eeee40951b03de5b543d15fbf0f419f1a7aff2f.zip
Version bump. Add a patch from upstream to fix build with GCC 4.7, wrt bug #423337.
(Portage version: 2.1.11.1/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/gluon/gluon-0.71.0.ebuild')
-rw-r--r--media-libs/gluon/gluon-0.71.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/gluon/gluon-0.71.0.ebuild b/media-libs/gluon/gluon-0.71.0.ebuild
new file mode 100644
index 000000000000..a706dc4b27de
--- /dev/null
+++ b/media-libs/gluon/gluon-0.71.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gluon/gluon-0.71.0.ebuild,v 1.1 2012/06/24 17:13:48 kensington Exp $
+
+EAPI=4
+
+OPENGL_REQUIRED="always"
+inherit kde4-base versionator
+
+DESCRIPTION="Gluon is a Free and Open Source framework for creating and distributing games."
+HOMEPAGE="http://gluon.tuxfamily.org/"
+SRC_URI="mirror://kde/unstable/${PN}/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+SLOT="4"
+IUSE="debug examples"
+
+DEPEND="
+ media-libs/alure
+ media-libs/libsndfile
+ media-libs/openal
+ virtual/glu
+ virtual/opengl
+ x11-libs/qt-declarative:4
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use examples INSTALL_EXAMPLES)
+ )
+
+ kde4-base_src_configure
+}