summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-11-04 11:00:58 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-11-04 11:00:58 +0000
commitbf2653af422cc4e700b97c72f8100dac28a81608 (patch)
tree900ce97f5704cb7a05c3a8736d9d4820057e0a8b /media-sound/audtty/audtty-0.1.12.ebuild
parentAdded 5.3.9 RC1. The PHP release candidates are now released directly to ~arch (diff)
downloadgentoo-2-bf2653af422cc4e700b97c72f8100dac28a81608.tar.gz
gentoo-2-bf2653af422cc4e700b97c72f8100dac28a81608.tar.bz2
gentoo-2-bf2653af422cc4e700b97c72f8100dac28a81608.zip
Version bump. Address underlinking as pointed out by Diego Elio Pettenò in bug #369707.
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/audtty/audtty-0.1.12.ebuild')
-rw-r--r--media-sound/audtty/audtty-0.1.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/audtty/audtty-0.1.12.ebuild b/media-sound/audtty/audtty-0.1.12.ebuild
new file mode 100644
index 000000000000..f9fd47e04461
--- /dev/null
+++ b/media-sound/audtty/audtty-0.1.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audtty/audtty-0.1.12.ebuild,v 1.1 2011/11/04 11:00:57 chainsaw Exp $
+
+EAPI=4
+inherit autotools base toolchain-funcs
+
+DESCRIPTION="Control Audacious from the command line with a friendly ncurses interface"
+HOMEPAGE="http://audtty.alioth.debian.org"
+SRC_URI="http://www.code-monkeys.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ >=media-sound/audacious-2.4.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-cc-and-destdir.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog README
+}
+
+pkg_postinst() {
+ elog "In order to run audtty over ssh or on a seperate TTY locally you need"
+ elog "to download and run the following script in a terminal on your desktop:"
+ elog ""
+ elog "http://${PN}.alioth.debian.org/dbus.sh"
+ elog ""
+ elog "Once run you will need to add ~/.dbus-session to your ~/.bashrc file."
+}