summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-25 17:24:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-25 17:24:22 +0000
commitc6f7da2436ead537667679b74f2e5aa731894326 (patch)
tree2ab6ac20c6aac820ad32025d2c89bbd13f506796 /media-sound/noteedit/files
parentStable on ppc64; bug #226991 (diff)
downloadgentoo-2-c6f7da2436ead537667679b74f2e5aa731894326.tar.gz
gentoo-2-c6f7da2436ead537667679b74f2e5aa731894326.tar.bz2
gentoo-2-c6f7da2436ead537667679b74f2e5aa731894326.zip
fix build with gcc 4.3 with tse3 useflag on, by Markus Rathgeb <maggu2810@web.de>, bug #229291
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-sound/noteedit/files')
-rw-r--r--media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch b/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch
new file mode 100644
index 000000000000..d5a2238b8834
--- /dev/null
+++ b/media-sound/noteedit/files/noteedit-2.8.1+gcc-4.3.1.patch
@@ -0,0 +1,28 @@
+diff -Naur noteedit-2.8.1.orig/configure.in.in noteedit-2.8.1/configure.in.in
+--- noteedit-2.8.1.orig/configure.in.in 2006-03-27 08:07:18.000000000 +0200
++++ noteedit-2.8.1/configure.in.in 2008-06-24 23:04:48.000000000 +0200
+@@ -275,10 +275,10 @@
+
+ fi
+ cat >tse3vtest.cc << EOF
+-#include <istream.h>
++#include <iostream>
+ #include <tse3/TSE3.h>
+ int main() {
+- cout << TSE3::TSE3_Version() << endl;
++ std::cout << TSE3::TSE3_Version() << std::endl;
+ return 0;
+ }
+ EOF
+diff -Naur noteedit-2.8.1.orig/kguitar_excerpt/fingerlist.cpp noteedit-2.8.1/kguitar_excerpt/fingerlist.cpp
+--- noteedit-2.8.1.orig/kguitar_excerpt/fingerlist.cpp 2006-03-26 22:54:31.000000000 +0200
++++ noteedit-2.8.1/kguitar_excerpt/fingerlist.cpp 2008-06-24 23:04:24.000000000 +0200
+@@ -21,7 +21,7 @@
+ #if GCC_MAJ_VERS > 2
+ #include <istream>
+ #else
+-#include <istream.h>
++#include <istream>
+ #endif
+ #include <qpainter.h>
+ #include <qcolor.h>