summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-05-27 19:44:17 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-05-27 19:44:17 +0000
commite0781fa5eb3624af66bb3aae7bb8cd3ecfba5a1d (patch)
tree1b2bdf5055a36eeeb1789ef59584c502436bc208 /media-video/drip
parentnew version (diff)
downloadgentoo-2-e0781fa5eb3624af66bb3aae7bb8cd3ecfba5a1d.tar.gz
gentoo-2-e0781fa5eb3624af66bb3aae7bb8cd3ecfba5a1d.tar.bz2
gentoo-2-e0781fa5eb3624af66bb3aae7bb8cd3ecfba5a1d.zip
fixes
Diffstat (limited to 'media-video/drip')
-rw-r--r--media-video/drip/ChangeLog12
-rw-r--r--media-video/drip/drip-0.8.1-r4.ebuild116
-rw-r--r--media-video/drip/files/digest-drip-0.8.1-r41
-rw-r--r--media-video/drip/files/drip-0.8.1-fix-dvd-symlink.patch29
-rw-r--r--media-video/drip/files/drip-0.8.1-missing-stdio.patch20
-rw-r--r--media-video/drip/files/dripgetdvd.sh20
6 files changed, 197 insertions, 1 deletions
diff --git a/media-video/drip/ChangeLog b/media-video/drip/ChangeLog
index 62e3ca4af4d5..a2fb5f7045ef 100644
--- a/media-video/drip/ChangeLog
+++ b/media-video/drip/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/drip
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.5 2002/05/26 14:05:33 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/ChangeLog,v 1.6 2002/05/27 19:44:17 azarah Exp $
+
+*drip-0.8.1-r4 (27 May 2002)
+
+ 27 May 2002; M.Schlemmer <azarah@gentoo.org> drip-0.8.1-r4.ebuild :
+
+ Resolve bug #3052. Seems the older divx4linux headers included
+ stdio.h, and I missed it due to multiple versions on my system.
+
+ Also fix the startup problem if /dev/dvd are not an absolute
+ symlink.
*drip-0.8.1-r3 (26 May 2002)
diff --git a/media-video/drip/drip-0.8.1-r4.ebuild b/media-video/drip/drip-0.8.1-r4.ebuild
new file mode 100644
index 000000000000..8f557ed8a1e8
--- /dev/null
+++ b/media-video/drip/drip-0.8.1-r4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@cvs.gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/drip/drip-0.8.1-r4.ebuild,v 1.1 2002/05/27 19:44:17 azarah Exp $
+
+AF_MINOR_VER="$(avifile-config --data-dir | cut -d. -f2)"
+S=${WORKDIR}/${P}
+DESCRIPTION="Drip - A DVD to DIVX convertor frontend"
+SRC_URI="${SRC_URI} http://drip.sourceforge.net/files/${P}.tar.gz"
+HOMEPAGE="http://drip.sourceforge.net/"
+
+RDEPEND="gnome-base/gnome-libs
+ >=media-video/avifile-0.7.4.20020426-r2
+ >=media-libs/a52dec-0.7.3
+ >=media-libs/divx4linux-20020418
+ >=media-libs/libdvdcss-1.1.1
+ >=media-libs/libdvdread-0.9.2
+ media-libs/gdk-pixbuf"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ >=sys-devel/automake-1.5-r1"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ # Fix the problem that if the /dev/dvd symlink is not absolute,
+ # drip fails to start.
+ patch -p1 < ${FILESDIR}/${P}-fix-dvd-symlink.patch || die
+
+ # Fix hardcoded path of plugins
+ cd ${S}
+ cp encoder/plugin-loader.cpp encoder/plugin-loader.cpp.orig
+ sed -e "s:/usr/local/lib:/usr/lib:g" \
+ encoder/plugin-loader.cpp.orig >encoder/plugin-loader.cpp
+
+ # Fix missing #include <stdio.h>
+ patch -p1 < ${FILESDIR}/${P}-missing-stdio.patch || die
+
+ # Fixup to work with avifile-0.${AF_MINOR_VER}
+ cd ${S}/encoder
+ for x in encoder.hh main.hh encoder.cpp external.cpp
+ do
+ cp ${x} ${x}.orig
+ sed -e "s:AVIFILE_MINOR_VERSION==6:AVIFILE_MINOR_VERSION==${AF_MINOR_VER}:g" \
+ ${x}.orig >${x}
+ done
+
+ # Fix it to work with the suffix the new avifile introduces.
+# cd ${S}
+# for x in $(find . -name 'Makefile.am') configure.in
+# do
+# cp ${x} ${x}.orig
+# sed -e "s:avifile-config:avifile-config0.${AF_MINOR_VER}:g" \
+# ${x}.orig >${x}
+# done
+
+ cd ${S}
+ # Remove stale script ... "automake --add-missing" will add it again
+ rm -f ${S}/missing
+ export WANT_AUTOMAKE_1_5=1
+ aclocal -I macros
+ automake --add-missing
+ autoconf
+}
+
+src_compile() {
+
+ export WANT_AUTOMAKE_1_5=1
+
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ CFLAGS= \
+ CXXFLAGS= \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var/lib \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ localstatedir=${D}/var/lib \
+ sysconfdir=${D}/etc \
+ drip_helpdir=${D}/usr/share/gnome/help/drip/C \
+ drip_pixmapdir=${D}/usr/share/pixmaps \
+ install || die
+
+ # Remove liba52.so.* as ac52dec provides this
+ rm ${D}/usr/lib/liba52*
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+
+ # Custom script for drip to get the *real* dvd device
+ # It is a bit rough around the edges, but hopefully will do the trick.
+ dobin ${FILESDIR}/dripgetdvd.sh
+
+ insinto /usr/share/pixmaps
+ newins ${S}/pixmaps/drip_logo.jpg drip.jpg
+ insinto /usr/share/gnome/apps/Multimedia
+ doins ${FILESDIR}/drip.desktop
+}
+
diff --git a/media-video/drip/files/digest-drip-0.8.1-r4 b/media-video/drip/files/digest-drip-0.8.1-r4
new file mode 100644
index 000000000000..53af5b8fffdc
--- /dev/null
+++ b/media-video/drip/files/digest-drip-0.8.1-r4
@@ -0,0 +1 @@
+MD5 b88e9731f7266f0e0b9ff412c13a3624 drip-0.8.1.tar.gz 603487
diff --git a/media-video/drip/files/drip-0.8.1-fix-dvd-symlink.patch b/media-video/drip/files/drip-0.8.1-fix-dvd-symlink.patch
new file mode 100644
index 000000000000..d6a8627578f0
--- /dev/null
+++ b/media-video/drip/files/drip-0.8.1-fix-dvd-symlink.patch
@@ -0,0 +1,29 @@
+--- drip-0.8.1/src/main.c Mon May 27 21:36:47 2002
++++ drip-0.8.1.azarah/src/main.c Mon May 27 21:39:54 2002
+@@ -231,10 +231,14 @@
+ device = g_string_new("");
+
+ /* Look for a device in mtab */
+- device = drip_system("grep dvd /etc/fstab | awk '{print $1}'",&result,FALSE,TRUE);
++ device = drip_system("/usr/bin/dripgetdvd.sh dvd",&result,FALSE,TRUE);
+ if (device->len==0 || strstr(device->str,"{empty output}")!=NULL) {
+- /* Couldn't find anything. Safe default */
+- g_string_sprintf(device,"%s","/dev/cdrom");
++ /* Couldn't find anything related to dvd, trying cdrom */
++ device = drip_system("/usr/bin/dripgetdvd.sh cdrom",&result,FALSE,TRUE);
++ if (device->len==0 || strstr(device->str,"{empty output}")!=NULL) {
++ /* Nothing we can do to stop failure, set default */
++ g_string_sprintf(device,"%s","/dev/cdrom");
++ }
+ }
+ return device->str;
+ }
+@@ -591,7 +595,7 @@
+ if (config_ok == FALSE) {
+ /* Default divx related settings */
+ g_log(DRIP_LD,G_LOG_LEVEL_INFO,"Setting up default configuration...");
+- g_string_sprintf(Config.DVDdevice,"%s","/dev/cdrom");
++ g_string_sprintf(Config.DVDdevice,"%s",detect_dvdrom());
+ /* Traceback if Config.DVDdevice is a symbolic link */
+ DVDsymlink();
+
diff --git a/media-video/drip/files/drip-0.8.1-missing-stdio.patch b/media-video/drip/files/drip-0.8.1-missing-stdio.patch
new file mode 100644
index 000000000000..8820f183f388
--- /dev/null
+++ b/media-video/drip/files/drip-0.8.1-missing-stdio.patch
@@ -0,0 +1,20 @@
+--- drip-0.8.1/encoder/demuxer.cpp Mon May 27 20:37:12 2002
++++ drip-0.8.1.azarah/encoder/demuxer.cpp Mon May 27 20:37:33 2002
+@@ -10,6 +10,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <stdio.h>
+ #include "fast_memcpy.hh"
+
+
+--- drip-0.8.1/encoder/encoder.cpp Mon May 27 20:35:57 2002
++++ drip-0.8.1.orig/encoder/encoder.cpp Mon May 27 20:39:10 2002
+@@ -15,6 +15,7 @@
+ #include <gtk/gtk.h>
+ #include <unistd.h>
+ #include <fstream>
++#include <stdio.h>
+ #include <errno.h>
+ #include <pthread.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
diff --git a/media-video/drip/files/dripgetdvd.sh b/media-video/drip/files/dripgetdvd.sh
new file mode 100644
index 000000000000..3e07b9c39940
--- /dev/null
+++ b/media-video/drip/files/dripgetdvd.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if test -z "$1"
+then
+ exit 1
+fi
+
+DVD="`grep $1 /etc/fstab | awk '{print $1}'`"
+
+while test -L "${DVD}"
+do
+ NEWDVD="`readlink ${DVD}`"
+ if test -z "`echo ${NEWDVD} |grep -e "^/dev"`"
+ then
+ DVD="${DVD%/*}/${NEWDVD}"
+ fi
+done
+
+echo ${DVD}
+