summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-15 21:18:38 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-15 21:18:38 +0000
commit2666444d3b03e0d51626d09eb7657bbbd2e7b512 (patch)
tree45d1db215bad9527638fb5219bed91535a04ec48 /net-analyzer/argus/files
parentInherit autotools for eautoreconf #390605 by Alexander Stein. (diff)
downloadgentoo-2-2666444d3b03e0d51626d09eb7657bbbd2e7b512.tar.gz
gentoo-2-2666444d3b03e0d51626d09eb7657bbbd2e7b512.tar.bz2
gentoo-2-2666444d3b03e0d51626d09eb7657bbbd2e7b512.zip
Remove redundant sed script. Tweak Makefile patch to actually die properly.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus/files')
-rw-r--r--net-analyzer/argus/files/argus-3.0.5-Makefile.patch13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
index e4c3e1981c2f..87b1c155caf8 100644
--- a/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
+++ b/net-analyzer/argus/files/argus-3.0.5-Makefile.patch
@@ -2,12 +2,19 @@ Do not continue when a sub-make errors (bug #380953).
--- a/Makefile.in
+++ b/Makefile.in
-@@ -55,7 +55,7 @@
+@@ -55,11 +55,11 @@
.PHONY: install installdirs all
all: force
- @-for d in $(DIRS);\
+ @for d in $(DIRS);\
do \
- (cd $$d; echo "### Making in" `pwd`;\
- $(MAKE) $(MFLAGS) ;\
+- (cd $$d; echo "### Making in" `pwd`;\
+- $(MAKE) $(MFLAGS) ;\
+- echo "### Done with" `pwd`);\
++ echo "### Making in" $$d;\
++ $(MAKE) -C $$d $(MFLAGS) || exit 1;\
++ echo "### Done with" $$d;\
+ done
+
+ install: force