summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-03-22 23:11:48 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-03-22 23:11:48 +0000
commitd7c9f84152952d1f7f3c92ffd005abe66f235cd8 (patch)
tree5c5b5d08ac28e1044410d92c1810ca36db7c0db7 /net-analyzer/scanlogd/scanlogd-2.2.5.ebuild
parentneeded to bump for gnustep.eclass changes per bug 86089 (diff)
downloadgentoo-2-d7c9f84152952d1f7f3c92ffd005abe66f235cd8.tar.gz
gentoo-2-d7c9f84152952d1f7f3c92ffd005abe66f235cd8.tar.bz2
gentoo-2-d7c9f84152952d1f7f3c92ffd005abe66f235cd8.zip
version bump, use enewuser
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/scanlogd/scanlogd-2.2.5.ebuild')
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild
new file mode 100644
index 000000000000..6a82a7e345d0
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild,v 1.1 2005/03/22 23:11:48 vanquirius Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Scanlogd - detects and logs TCP port scans"
+SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/libc"
+
+pkg_setup() {
+ enewgroup scanlogd
+ enewuser scanlogd -1 /bin/false /dev/null scanlogd
+}
+
+src_compile() {
+ make linux || die
+}
+
+src_install() {
+ dosbin scanlogd
+ doman scanlogd.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/scanlogd.rc scanlogd
+}
+
+pkg_postinst() {
+ einfo "You can start the scanlogd monitoring program at boot by running"
+ einfo "rc-update add scanlogd default"
+}