summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scanlogd/scanlogd-2.2.5.ebuild')
-rw-r--r--net-analyzer/scanlogd/scanlogd-2.2.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild b/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild
new file mode 100644
index 000000000000..6a82a7e345d0
--- /dev/null
+++ b/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scanlogd/scanlogd-2.2.5.ebuild,v 1.1 2005/03/22 23:11:48 vanquirius Exp $
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="Scanlogd - detects and logs TCP port scans"
+SRC_URI="http://www.openwall.com/scanlogd/${P}.tar.gz"
+HOMEPAGE="http://www.openwall.com/scanlogd/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/libc"
+
+pkg_setup() {
+ enewgroup scanlogd
+ enewuser scanlogd -1 /bin/false /dev/null scanlogd
+}
+
+src_compile() {
+ make linux || die
+}
+
+src_install() {
+ dosbin scanlogd
+ doman scanlogd.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/scanlogd.rc scanlogd
+}
+
+pkg_postinst() {
+ einfo "You can start the scanlogd monitoring program at boot by running"
+ einfo "rc-update add scanlogd default"
+}