summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-12 13:59:20 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-12 13:59:20 +0000
commitb9721dc02d42b5e5b640a9cf5dad6cb8d5cfa76c (patch)
tree8931317bdc43b7c3421287c8e321eb18213cfad0 /net-dialup
parentVersion bump. Closing bug #28473. (diff)
downloadgentoo-2-b9721dc02d42b5e5b640a9cf5dad6cb8d5cfa76c.tar.gz
gentoo-2-b9721dc02d42b5e5b640a9cf5dad6cb8d5cfa76c.tar.bz2
gentoo-2-b9721dc02d42b5e5b640a9cf5dad6cb8d5cfa76c.zip
added blurb about groups needed
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/wvdial/ChangeLog6
-rw-r--r--net-dialup/wvdial/Manifest6
-rw-r--r--net-dialup/wvdial/wvdial-1.53-r1.ebuild32
3 files changed, 30 insertions, 14 deletions
diff --git a/net-dialup/wvdial/ChangeLog b/net-dialup/wvdial/ChangeLog
index b9ca14da23d9..22e3ce8813f3 100644
--- a/net-dialup/wvdial/ChangeLog
+++ b/net-dialup/wvdial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/wvdial
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.11 2003/08/21 22:50:28 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/ChangeLog,v 1.12 2003/09/12 13:59:18 seemant Exp $
+
+ 12 Sep 2003; Seemant Kulleen <seemant@gentoo.org> wvdial-1.53-r1.ebuild:
+ added postinst blurb that users MUST be in BOTH the dialout and uucp groups to
+ use wvdial. Thanks to: Björn Michaelsen <bmichaelsen@t-email.de> in bug #27506
21 Aug 2003; Will Woods <wwoods@gentoo.org> wvdial-1.53-r1.ebuild:
Marked stable for alpha
diff --git a/net-dialup/wvdial/Manifest b/net-dialup/wvdial/Manifest
index 1abd0faf3b3f..12c234a40223 100644
--- a/net-dialup/wvdial/Manifest
+++ b/net-dialup/wvdial/Manifest
@@ -1,4 +1,4 @@
-MD5 87d4c06627c2ad13886cb74b7de3c24e ChangeLog 1625
-MD5 3ac46ab0f9fe80d5347ca4541c722cf6 wvdial-1.53-r1.ebuild 1033
-MD5 dd6d40650ac9dab6a45f71a9cadbc7a9 files/digest-wvdial-1.53-r1 62
+MD5 da79cfd80ad8cb12733b91f5cf59086b wvdial-1.53-r1.ebuild 1154
+MD5 fe91c6b9a6ea72daa11d4f02aff28519 ChangeLog 1864
MD5 10b5850b5a52a665bc8cb8ffc7b06bd9 files/wvdial-1.53-crypt.patch 381
+MD5 dd6d40650ac9dab6a45f71a9cadbc7a9 files/digest-wvdial-1.53-r1 62
diff --git a/net-dialup/wvdial/wvdial-1.53-r1.ebuild b/net-dialup/wvdial/wvdial-1.53-r1.ebuild
index d22e8bc7a16e..1c3cb36edf20 100644
--- a/net-dialup/wvdial/wvdial-1.53-r1.ebuild
+++ b/net-dialup/wvdial/wvdial-1.53-r1.ebuild
@@ -1,14 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.53-r1.ebuild,v 1.6 2003/09/07 00:09:22 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/wvdial/wvdial-1.53-r1.ebuild,v 1.7 2003/09/12 13:59:18 seemant Exp $
+
+inherit eutils
S=${WORKDIR}/${P}
DESCRIPTION="Excellent program which automatically configures your PPP session"
SRC_URI="http://open.nit.ca/download/${P}.tar.gz"
HOMEPAGE="http://open.nit.ca/"
-DEPEND="net-libs/wvstreams"
-RDEPEND="${DEPEND} net-dialup/ppp"
+DEPEND=">=sys-apps/sed-4
+ net-libs/wvstreams"
+
+RDEPEND="${DEPEND}
+ net-dialup/ppp"
SLOT="0"
LICENSE="LGPL-2"
@@ -18,21 +23,17 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-crypt.patch || die "Patch failed"
+ epatch ${FILESDIR}/${P}-crypt.patch
}
src_compile() {
- cp Makefile Makefile.orig
- sed -e "s:PREFIX=/usr/local:PREFIX=/usr:" \
- Makefile.orig > Makefile
+ sed -i "s:PREFIX=/usr/local:PREFIX=/usr:" Makefile
}
src_install() {
- cp Makefile Makefile.orig
- sed -e "s:PPPDIR=/etc/ppp/peers:PPPDIR=${D}/etc/ppp/peers:" \
- Makefile.orig > Makefile
+ sed -i "s:PPPDIR=/etc/ppp/peers:PPPDIR=${D}/etc/ppp/peers:" Makefile
make \
PREFIX=${D}/usr \
@@ -41,3 +42,14 @@ src_install() {
dodoc ANNOUNCE CHANGES COPYING.LIB README
dodoc debian/copyright debian/changelog
}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Use wvdialconf to automagically generate a configuration-file."
+ einfo
+ einfo "Users have to be member of the dialout AND the uucp group"
+ einfo "to use wvdial!"
+ einfo
+}
+