summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-05-28 05:23:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-05-28 05:23:26 +0000
commit516da738e0ec8826d740f6c2ace59ed2dc33d5fc (patch)
treee6ae677c667929bf302486eebbf9dfd897a03b41 /net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch
parenteverytime you don't quote a variable "" kills a kitten (diff)
downloadgentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.tar.gz
gentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.tar.bz2
gentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.zip
Fix build failure due to underlinking and silence excessive warnings with gcc-4.8 (bug #458164, thanks to Ted Tanberry and Mike Frysinger).
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch')
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch
new file mode 100644
index 000000000000..2e0ae62b8673
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch
@@ -0,0 +1,49 @@
+From 3c499aa2a70b06b40a64fb5699622ff458e4ee0f Mon Sep 17 00:00:00 2001
+From: Kalev Lember <kalevlember@gmail.com>
+Date: Sun, 25 Nov 2012 03:26:42 +0100
+Subject: [PATCH] [GTK] Explicitly link against librt
+
+Fixes broken build with undefined references to shm_open / shm_unlink
+symbols. SharedMemoryUnix.cpp uses these so we need to link with -lrt.
+
+https://bugs.webkit.org/show_bug.cgi?id=103194
+---
+ ChangeLog | 12 ++++++++++++
+ Source/WebKit2/ChangeLog | 12 ++++++++++++
+ Source/WebKit2/GNUmakefile.am | 1 +
+ configure.ac | 7 +++++++
+ 4 files changed, 32 insertions(+)
+
+diff --git a/Source/WebKit2/GNUmakefile.am b/Source/WebKit2/GNUmakefile.am
+index 9a02bbd..c775990 100644
+--- a/Source/WebKit2/GNUmakefile.am
++++ b/Source/WebKit2/GNUmakefile.am
+@@ -572,6 +572,7 @@ Programs_WebKitPluginProcess_LDADD += \
+ $(PANGO_LIBS) \
+ $(PNG_LIBS) \
+ $(SHLWAPI_LIBS) \
++ $(SHM_LIBS) \
+ $(SQLITE3_LIBS) \
+ $(UNICODE_LIBS) \
+ $(XRENDER_LIBS) \
+diff --git a/configure.ac b/configure.ac
+index 4e1f0e8..97980e4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1118,6 +1118,13 @@ if test "$enable_webkit2" = "yes"; then
+ if test "$have_gtk_unix_printing" = "yes"; then
+ AC_DEFINE([HAVE_GTK_UNIX_PRINTING], [1], [Define if GTK+ UNIX Printing is available])
+ fi
++
++ # On some Linux/Unix platforms, shm_* may only be available if linking
++ # against librt
++ if test "$os_win32" = "no"; then
++ AC_SEARCH_LIBS([shm_open], [rt], [SHM_LIBS="-lrt"])
++ AC_SUBST(SHM_LIBS)
++ fi
+ fi
+
+ # Plugin Process
+--
+1.8.0
+