summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-05-02 22:37:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-05-02 22:37:34 +0000
commitb6ba8e71ccac94a8c5b7b1c2617f3c4ca9afde1a (patch)
tree93b7f822145d231c43296a9bd5b6265c4afe6775 /net-mail/mhonarc-gentoo
parentInitial commit of the MHonArc's Gentoo fork (diff)
downloadgentoo-2-b6ba8e71ccac94a8c5b7b1c2617f3c4ca9afde1a.tar.gz
gentoo-2-b6ba8e71ccac94a8c5b7b1c2617f3c4ca9afde1a.tar.bz2
gentoo-2-b6ba8e71ccac94a8c5b7b1c2617f3c4ca9afde1a.zip
Cleanup: EAPI 4, use perl-module instead of perl-app eclass, introduce a MY_P var, remove prepalldocs, move the patch to a PATCHES array
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/mhonarc-gentoo')
-rw-r--r--net-mail/mhonarc-gentoo/ChangeLog7
-rw-r--r--net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild22
2 files changed, 15 insertions, 14 deletions
diff --git a/net-mail/mhonarc-gentoo/ChangeLog b/net-mail/mhonarc-gentoo/ChangeLog
index 667eb78eeb15..3965fb95944d 100644
--- a/net-mail/mhonarc-gentoo/ChangeLog
+++ b/net-mail/mhonarc-gentoo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mhonarc-gentoo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/ChangeLog,v 1.1 2011/05/02 22:21:32 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/ChangeLog,v 1.2 2011/05/02 22:37:34 tampakrap Exp $
+
+ 02 May 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ mhonarc-gentoo-2.6.18.ebuild:
+ Cleanup: EAPI 4, use perl-module instead of perl-app eclass, introduce a MY_P
+ var, remove prepalldocs, move the patch to a PATCHES array
*mhonarc-gentoo-2.6.18 (02 May 2011)
diff --git a/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
index 03e48b596a7c..ee28b9f5a905 100644
--- a/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
+++ b/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild
@@ -1,34 +1,30 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild,v 1.1 2011/05/02 22:21:32 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mhonarc-gentoo/mhonarc-gentoo-2.6.18.ebuild,v 1.2 2011/05/02 22:37:34 tampakrap Exp $
-inherit perl-app
+EAPI=4
-IUSE=""
-
-SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
-RESTRICT="mirror"
+inherit perl-module
DESCRIPTION="Perl Mail-to-HTML Converter, Gentoo fork"
HOMEPAGE="http://www.mhonarc.org/"
LICENSE="GPL-2"
+SRC_URI="http://www.mhonarc.org/release/MHonArc/tar/MHonArc-${PV}.tar.bz2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE=""
RDEPEND="!net-mail/mhonarc"
-S="${WORKDIR}/${P/mhonarc-gentoo/MHonArc}"
+MY_P="${P/mhonarc-gentoo/MHonArc}"
+S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-archives-gentoo.patch
-}
+PATCHES=( "${FILESDIR}/${P}-archives-gentoo.patch" )
src_install() {
sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}' -prefix '${D}'|g" -i Makefile
sed -e "s|installsitelib|installvendorlib|g" -i install.me
+
perl-module_src_install
- prepalldocs
}