summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2004-01-16 16:44:03 +0000
committerMax Kalika <max@gentoo.org>2004-01-16 16:44:03 +0000
commitaa33a0b01978c34614127f135b30f2e92e26841f (patch)
treed41a7b2f0f5dce29edd17f7d019201c4aa82d0c6 /net-mail/postfix/postfix-2.0.16-r1.ebuild
parentCleanup. (diff)
downloadgentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.tar.gz
gentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.tar.bz2
gentoo-2-aa33a0b01978c34614127f135b30f2e92e26841f.zip
Provide proper include path for PostgreSQL depending on which version is installed. Fixes bug #38401.
Diffstat (limited to 'net-mail/postfix/postfix-2.0.16-r1.ebuild')
-rw-r--r--net-mail/postfix/postfix-2.0.16-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-mail/postfix/postfix-2.0.16-r1.ebuild b/net-mail/postfix/postfix-2.0.16-r1.ebuild
index 3878b7ccec2f..25c0c3237d4d 100644
--- a/net-mail/postfix/postfix-2.0.16-r1.ebuild
+++ b/net-mail/postfix/postfix-2.0.16-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.10 2004/01/14 20:38:12 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-2.0.16-r1.ebuild,v 1.11 2004/01/16 16:44:03 max Exp $
inherit eutils ssl-cert
@@ -109,7 +109,11 @@ src_compile() {
mylibs="${mylibs} -lmysqlclient -lm -lz"
fi
if [ "`use postgres`" ] ; then
- mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql"
+ if [ "`best_version '=dev-db/postgresql-7.3*'`" ] ; then
+ mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql"
+ else
+ mycc="${mycc} -DHAS_PGSQL -I/usr/include/postgresql/pgsql"
+ fi
mylibs="${mylibs} -lpq"
fi
if [ "`use ssl`" ] ; then