summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:49:57 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:49:57 +0000
commit9c2d314f0a5c52c640f4fb6a00b7bede2ab9efc6 (patch)
tree86c0ed6175968280fe0da73d6f70f5bb3dc755e6 /net-www/mod_tcl
parentnew Apache2 mod (diff)
downloadgentoo-2-9c2d314f0a5c52c640f4fb6a00b7bede2ab9efc6.tar.gz
gentoo-2-9c2d314f0a5c52c640f4fb6a00b7bede2ab9efc6.tar.bz2
gentoo-2-9c2d314f0a5c52c640f4fb6a00b7bede2ab9efc6.zip
new Apache2 mod
Diffstat (limited to 'net-www/mod_tcl')
-rw-r--r--net-www/mod_tcl/ChangeLog8
-rw-r--r--net-www/mod_tcl/files/27_mod_tcl.conf12
-rw-r--r--net-www/mod_tcl/files/digest-mod_tcl-1.01
-rw-r--r--net-www/mod_tcl/mod_tcl-1.0.ebuild30
4 files changed, 51 insertions, 0 deletions
diff --git a/net-www/mod_tcl/ChangeLog b/net-www/mod_tcl/ChangeLog
new file mode 100644
index 000000000000..bf825f45e86c
--- /dev/null
+++ b/net-www/mod_tcl/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_tcl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_tcl/ChangeLog,v 1.1 2002/11/28 20:49:57 woodchip Exp $
+
+*mod_tcl-1.0 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_tcl/files/27_mod_tcl.conf b/net-www/mod_tcl/files/27_mod_tcl.conf
new file mode 100644
index 000000000000..fe25a22f0f09
--- /dev/null
+++ b/net-www/mod_tcl/files/27_mod_tcl.conf
@@ -0,0 +1,12 @@
+<IfDefine TCL>
+ <IfModule !mod_tcl.c>
+ LoadModule tcl_module extramodules/mod_tcl.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_tcl.c>
+
+# See http://tcl.apache.org/mod_tcl/ for now :/
+
+</IfModule>
+
diff --git a/net-www/mod_tcl/files/digest-mod_tcl-1.0 b/net-www/mod_tcl/files/digest-mod_tcl-1.0
new file mode 100644
index 000000000000..84e97909dea1
--- /dev/null
+++ b/net-www/mod_tcl/files/digest-mod_tcl-1.0
@@ -0,0 +1 @@
+MD5 7ccd4ae97417baec0e0b7ec8c981ac32 mod_tcl-1.0.tar.bz2 18741
diff --git a/net-www/mod_tcl/mod_tcl-1.0.ebuild b/net-www/mod_tcl/mod_tcl-1.0.ebuild
new file mode 100644
index 000000000000..6f763fb748bf
--- /dev/null
+++ b/net-www/mod_tcl/mod_tcl-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_tcl/mod_tcl-1.0.ebuild,v 1.1 2002/11/28 20:49:57 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 DSO providing an embedded Tcl interpreter"
+HOMEPAGE="http://tcl.apache.org/mod_tcl/"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+DEPEND="dev-lang/tcl =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ mv tcl_core.c ${PN}.c
+ apxs2 -c -Wl,-ltcl -DHAVE_TCL_H ${PN}.c tcl_cmds.c tcl_misc.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/27_mod_tcl.conf
+ dodoc ${FILESDIR}/27_mod_tcl.conf
+ dodoc AUTHORS INSTALL NEWS README test_script.tm
+}