summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:27:59 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 16:27:59 +0000
commit730b3eb3ed04dc13fc328751abbea63fe9e19243 (patch)
treeefaf4cbf56eaaca8551998bf70713bd951ffe27b /sci-chemistry/babel/babel-1.6.ebuild
parentMoving to sci-chemistry/babel (diff)
downloadgentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.tar.gz
gentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.tar.bz2
gentoo-2-730b3eb3ed04dc13fc328751abbea63fe9e19243.zip
Moved from app-sci/babel to sci-chemistry/babel.
Diffstat (limited to 'sci-chemistry/babel/babel-1.6.ebuild')
-rw-r--r--sci-chemistry/babel/babel-1.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-chemistry/babel/babel-1.6.ebuild b/sci-chemistry/babel/babel-1.6.ebuild
new file mode 100644
index 000000000000..5ea6c75f16ce
--- /dev/null
+++ b/sci-chemistry/babel/babel-1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/babel/babel-1.6.ebuild,v 1.1 2004/12/24 16:27:59 ribosome Exp $
+
+inherit eutils
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+
+HOMEPAGE="http://smog.com/chem/babel/"
+KEYWORDS="x86 ppc sparc ~amd64"
+SLOT="0"
+LICENSE="as-is"
+IUSE=""
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="!app-sci/openbabel"
+
+src_unpack() {
+
+ unpack ${P}.tar.Z
+ cd ${S}
+#Patch the Makefile for gentoo-isms
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gcc32.diff
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D}/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins ${S}/*.lis
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10babel
+
+ dodoc README.1ST
+
+}
+