summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-09-11 13:33:34 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-09-11 13:33:34 +0000
commitac706ccda4e86db0545f16ce75ae048fbbb0e59a (patch)
treedda60b88b918e55deedb7d9bc851f475ee4daf8f /sci-libs/qrupdate/files
parentBump (diff)
downloadgentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.tar.gz
gentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.tar.bz2
gentoo-2-ac706ccda4e86db0545f16ce75ae048fbbb0e59a.zip
Initial import into portage tree (fixes bug #282203).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/qrupdate/files')
-rw-r--r--sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch b/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch
new file mode 100644
index 000000000000..fa8925fd8bb6
--- /dev/null
+++ b/sci-libs/qrupdate/files/qrupdate-1.0.1-makefile.patch
@@ -0,0 +1,24 @@
+diff -Naur qrupdate-1.0.1/Makefile qrupdate-1.0.1.new/Makefile
+--- qrupdate-1.0.1/Makefile 2009-02-06 04:12:00.000000000 -0500
++++ qrupdate-1.0.1.new/Makefile 2009-09-10 09:55:32.000000000 -0400
+@@ -34,7 +34,7 @@
+ lib:
+ make -C src/ lib
+ solib:
+- make -C src/ solib
++ +make -C src/ solib
+ test: lib
+ make -C test/
+
+diff -Naur qrupdate-1.0.1/src/Makefile qrupdate-1.0.1.new/src/Makefile
+--- qrupdate-1.0.1/src/Makefile 2009-02-06 04:12:50.000000000 -0500
++++ qrupdate-1.0.1.new/src/Makefile 2009-09-10 09:49:29.000000000 -0400
+@@ -40,7 +40,7 @@
+ ar -cr $@ $(OBJS)
+
+ ../libqrupdate.so: $(OBJS)
+- $(FC) $(FFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) -shared -o $@ -Wl,-soname=libqrupdate.so.$(MAJOR) $(OBJS) \
+ $(BLAS) $(LAPACK)
+
+ $(OBJS): %.o: %.f