summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-15 02:51:34 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-15 02:51:34 +0000
commitbd653e0c2af2de308d5822fd809df5668a051ca9 (patch)
treef1607943f32a2008dfd6b49f78fa1b32d19090e8 /sys-apps/busybox
parentder, it would help if i had the ebuild actually apply the new patches ... (diff)
downloadgentoo-2-bd653e0c2af2de308d5822fd809df5668a051ca9.tar.gz
gentoo-2-bd653e0c2af2de308d5822fd809df5668a051ca9.tar.bz2
gentoo-2-bd653e0c2af2de308d5822fd809df5668a051ca9.zip
use append-flags, not CFLAGS=$CFLAGS
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild6
-rw-r--r--sys-apps/busybox/busybox-1.2.0.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index 5579a6f0e93f..d85be3df2dde 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.11 2006/07/10 17:54:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.12 2006/07/15 02:51:34 vapier Exp $
inherit eutils flag-o-matic
@@ -126,8 +126,8 @@ src_unpack() {
src_compile() {
busybox_set_env
- use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc `test-flags-CC -fno-stack-protector`"
- use ppc && CFLAGS="${CFLAGS} `test-flags-CC -fno-stack-protector`"
+ use ppc64 && append-flags -mminimal-toc $(test-flags-CC -fno-stack-protector)
+ use ppc && append-flags $(test-flags-CC -fno-stack-protector)
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}
diff --git a/sys-apps/busybox/busybox-1.2.0.ebuild b/sys-apps/busybox/busybox-1.2.0.ebuild
index 0f045df907b3..d2cd657b0d23 100644
--- a/sys-apps/busybox/busybox-1.2.0.ebuild
+++ b/sys-apps/busybox/busybox-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.3 2006/07/10 17:54:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.4 2006/07/15 02:51:34 vapier Exp $
inherit eutils flag-o-matic
@@ -126,8 +126,8 @@ src_unpack() {
src_compile() {
busybox_set_env
- use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc `test-flags-CC -fno-stack-protector`"
- use ppc && CFLAGS="${CFLAGS} `test-flags-CC -fno-stack-protector`"
+ use ppc64 && append-flags -mminimal-toc $(test-flags-CC -fno-stack-protector)
+ use ppc && append-flags $(test-flags-CC -fno-stack-protector)
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}