summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2011-12-07 22:01:17 +0000
committerNathan Phillip Brink <binki@gentoo.org>2011-12-07 22:01:17 +0000
commitd37f6ab4c9189ab4f5a93e94c1844accd83c8b0c (patch)
treef31bda7edb5301e4332fbd1ca0f001be87fda9aa /sys-apps/hwloc
parentVersion bump; remove old (diff)
downloadgentoo-2-d37f6ab4c9189ab4f5a93e94c1844accd83c8b0c.tar.gz
gentoo-2-d37f6ab4c9189ab4f5a93e94c1844accd83c8b0c.tar.bz2
gentoo-2-d37f6ab4c9189ab4f5a93e94c1844accd83c8b0c.zip
Force hwloc's ./configure to respect PKG_CONFIG, fixes bug #393467 and some portage-multilib compat.
(Portage version: 2.2.0_alpha78-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog7
-rw-r--r--sys-apps/hwloc/hwloc-1.2.1.ebuild7
-rw-r--r--sys-apps/hwloc/hwloc-1.3.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index a432071dba47..4a8d520a5d46 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.16 2011/11/20 14:13:21 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.17 2011/12/07 22:01:17 binki Exp $
+
+ 07 Dec 2011; Nathan Phillip Brink <binki@gentoo.org> hwloc-1.2.1.ebuild,
+ hwloc-1.3.ebuild:
+ Force hwloc's ./configure to respect PKG_CONFIG, fixes bug #393467 and some
+ portage-multilib compat.
*hwloc-1.3 (20 Nov 2011)
diff --git a/sys-apps/hwloc/hwloc-1.2.1.ebuild b/sys-apps/hwloc/hwloc-1.2.1.ebuild
index f9c5135c3b15..662743d86b54 100644
--- a/sys-apps/hwloc/hwloc-1.2.1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2.1.ebuild,v 1.2 2011/09/01 16:20:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2.1.ebuild,v 1.3 2011/12/07 22:01:17 binki Exp $
EAPI="4"
@@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
numa? ( sys-process/numactl )"
+pkg_setup() {
+ # Fix bug #393467, hwloc ignores PKG_CONFIG environment variable.
+ [[ ${PKG_CONFIG} ]] && export HWLOC_PKG_CONFIG=${PKG_CONFIG}
+}
+
src_configure() {
econf \
--docdir="${EPREFIX}/usr/share/doc/${P}" \
diff --git a/sys-apps/hwloc/hwloc-1.3.ebuild b/sys-apps/hwloc/hwloc-1.3.ebuild
index 740f9ec67400..e8b4eaabc753 100644
--- a/sys-apps/hwloc/hwloc-1.3.ebuild
+++ b/sys-apps/hwloc/hwloc-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.3.ebuild,v 1.1 2011/11/20 14:13:21 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.3.ebuild,v 1.2 2011/12/07 22:01:17 binki Exp $
EAPI=4
@@ -27,6 +27,11 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README VERSION )
+pkg_setup() {
+ # Fix bug #393467, hwloc ignores PKG_CONFIG environment variable.
+ [[ ${PKG_CONFIG} ]] && export HWLOC_PKG_CONFIG=${PKG_CONFIG}
+}
+
src_configure() {
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \