summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 20:31:01 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 20:31:01 +0000
commit49be4b066be587fbadbf42baf7181513bb68146b (patch)
tree7b4da58ada4d666b7b4568ddf6e7166b66196603 /sys-apps
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-49be4b066be587fbadbf42baf7181513bb68146b.tar.gz
gentoo-2-49be4b066be587fbadbf42baf7181513bb68146b.tar.bz2
gentoo-2-49be4b066be587fbadbf42baf7181513bb68146b.zip
QA - fix use invocation
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild20
-rw-r--r--sys-apps/baselayout/baselayout-1.8.6.13.ebuild24
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r1.ebuild4
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r2.ebuild10
-rw-r--r--sys-apps/coreutils/ChangeLog6
-rw-r--r--sys-apps/coreutils/coreutils-5.0-r6.ebuild6
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r3.ebuild8
-rw-r--r--sys-apps/coreutils/coreutils-5.0.91-r4.ebuild8
-rw-r--r--sys-apps/dbus/ChangeLog5
-rw-r--r--sys-apps/dbus/dbus-0.21.ebuild4
12 files changed, 61 insertions, 46 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index d5beaf65ab5b..981624457e28 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.152 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.153 2004/06/25 20:26:33 agriffis Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ baselayout-1.8.6.13-r1.ebuild, baselayout-1.8.6.13.ebuild:
+ QA - fix use invocation
+
15 Jun 2004; <solar@gentoo.org> baselayout-1.9.4-r2.ebuild:
remove unneeded /etc/nsswitch.conf with USE=uclibc
diff --git a/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild b/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
index ab8d7c3bbe6f..edfda3a11bde 100644
--- a/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild,v 1.8 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild,v 1.9 2004/06/25 20:26:33 agriffis Exp $
inherit eutils
@@ -41,7 +41,7 @@ src_unpack() {
cd ${S2}
cp Makefile Makefile.orig
sed -e "s:-O2:${CFLAGS}:" Makefile.orig >Makefile || die
- if [ -n "`use build`" ]
+ if use build
then
# Do not build sulogin, as it needs libcrypt which is not in the
# build image.
@@ -88,7 +88,7 @@ src_compile() {
make CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Build sysvinit stuff
cd ${S2}
@@ -350,7 +350,7 @@ src_install() {
# if 'build' or 'bootstrap' is not in USE. This will
# change if we have sys-apps/gawk-3.1.1-r1 or later in
# the build image ...
- if [ -z "`use build`" ]
+ if ! use build
then
# This is for new depscan.sh and env-update.sh
# written in awk
@@ -373,7 +373,7 @@ src_install() {
einfo "Installing utilities..."
make DESTDIR="${D}" install || die "problem installing utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Install sysvinit stuff
cd ${S2}
@@ -444,8 +444,8 @@ src_install() {
keepdir ${svcdir} >/dev/null 2>&1
- if [ -n "$(use build)" -o -n "$(use bootstrap)" -o \
- ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
+ if use build || use bootstrap || \
+ [ ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
# Ok, create temp device nodes
mkdir -p "${T}/udev-$$"
@@ -521,7 +521,7 @@ pkg_postinst() {
if [ "${altmerge}" -eq "0" -a ! -e "${ROOT}/dev/.udev" -a \
-f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
- if [ -n "$(use build)" -o -n "$(use bootstrap)" ]
+ if use build || use bootstrap
then
einfo "Populating /dev with device nodes..."
if [ -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
@@ -588,7 +588,7 @@ EOF
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a bootstrap.
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
@@ -597,7 +597,7 @@ EOF
# Reload init to fix unmounting problems of / on next reboot
# this is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [ "${ROOT}" = "/" -a -z "`use build`" -a -z "`use bootstrap`" ]
+ if [ "${ROOT}" = "/" ] && ! use build && ! use bootstrap
then
echo
# Do not return an error if this fails
diff --git a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
index 51dfc346e883..66e0390a1217 100644
--- a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.8 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.9 2004/06/25 20:26:33 agriffis Exp $
inherit eutils
@@ -44,7 +44,7 @@ src_unpack() {
cd ${S2}
cp Makefile Makefile.orig
sed -e "s:-O2:${CFLAGS}:" Makefile.orig >Makefile || die
- if [ -n "`use build`" ]
+ if use build
then
# Do not build sulogin, as it needs libcrypt which is not in the
# build image.
@@ -75,7 +75,7 @@ src_unpack() {
;;
esac
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
# Sanity check to see if has version works
if has_version '>=sys-apps/baselayout-1.8' &> /dev/null
@@ -101,7 +101,7 @@ src_compile() {
make CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Build sysvinit stuff
cd ${S2}
@@ -350,7 +350,7 @@ src_install() {
# if 'build' or 'bootstrap' is not in USE. This will
# change if we have sys-apps/gawk-3.1.1-r1 or later in
# the build image ...
- if [ -z "`use build`" ]
+ if ! use build
then
# This is for new depscan.sh and env-update.sh
# written in awk
@@ -373,7 +373,7 @@ src_install() {
einfo "Installing utilities..."
make DESTDIR="${D}" install || die "problem installing utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Install sysvinit stuff
cd ${S2}
@@ -444,8 +444,8 @@ src_install() {
keepdir ${svcdir} >/dev/null 2>&1
- if [ -n "$(use build)" -o -n "$(use bootstrap)" -o \
- ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
+ if use build || use bootstrap || \
+ [ ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
# Ok, create temp device nodes
mkdir -p "${T}/udev-$$"
@@ -555,7 +555,7 @@ pkg_postinst() {
if [ "${altmerge}" -eq "0" -a ! -e "${ROOT}/dev/.udev" -a \
-f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
- if [ -n "$(use build)" -o -n "$(use bootstrap)" ]
+ if use build || use bootstrap
then
einfo "Populating /dev with device nodes..."
[ ! -e "${ROOT}/dev" ] && mkdir -p "${ROOT}/dev"
@@ -616,7 +616,7 @@ EOF
# Make sure we get everything ready for $svcdir that moved to
# /var/lib/init.d ....
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
local oldsvcdir="${svcdir}"
local rcconfd="/etc/conf.d/rc"
@@ -675,7 +675,7 @@ EOF
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a bootstrap.
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
@@ -684,7 +684,7 @@ EOF
# Reload init to fix unmounting problems of / on next reboot
# this is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [ "${ROOT}" = "/" -a -z "`use build`" -a -z "`use bootstrap`" ]
+ if [ "${ROOT}" = "/" ] && ! use build && ! use bootstrap
then
echo
# Do not return an error if this fails
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 91fcd2c16cae..78899ac40c17 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.31 2004/06/24 21:59:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.32 2004/06/25 20:28:35 agriffis Exp $
+
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org> busybox-0.60.5-r1.ebuild,
+ busybox-0.60.5-r2.ebuild:
+ QA - fix use invocation
23 Jun 2004; <solar@gentoo.org> busybox-1.00_pre8.ebuild:
Added ~mips to the KEYWORDS after a successful compile
diff --git a/sys-apps/busybox/busybox-0.60.5-r1.ebuild b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
index 5ec8f9e54247..9957ec07521e 100644
--- a/sys-apps/busybox/busybox-0.60.5-r1.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.11 2004/06/24 21:59:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.12 2004/06/25 20:28:35 agriffis Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
@@ -25,7 +25,7 @@ src_unpack() {
src_compile() {
local myconf
use static && myconf="${myconf} DOSTATIC=true"
- if [ `use uclibc` ]; then
+ if use uclibc; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"
diff --git a/sys-apps/busybox/busybox-0.60.5-r2.ebuild b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
index 483c5ae5564b..643267216540 100644
--- a/sys-apps/busybox/busybox-0.60.5-r2.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.8 2004/06/24 21:59:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r2.ebuild,v 1.9 2004/06/25 20:28:35 agriffis Exp $
inherit flag-o-matic eutils
@@ -27,14 +27,14 @@ src_unpack() {
# I did not include the msh patch since I don't know if it will
# break stuff, I compile ash anyway, and it's in CVS
- if [ `use devfs` ]; then
+ if use devfs; then
einfo "Disabling devfs in busybox"
sed -i -e "s:#define.*BB_FEATURE_DEVFS://#define BB_FEATURE_DEVFS:g" \
${S}/Config.h
fi
# Add support for dietlibc - solar@gentoo.org
- if [ `use diet` ]; then
+ if use diet; then
[ "${PV}" == "0.60.5" ] &&
sed -i \
-e "s://#define.*BB_TTY:#define BB_TTY:g" \
@@ -51,14 +51,14 @@ src_compile() {
local myconf
use static && myconf="${myconf} DOSTATIC=true"
- if [ `use uclibc` ]; then
+ if use uclibc; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"
unset CFLAGS
fi
- if [ `use diet` ] ; then
+ if use diet ; then
append-flags -D_BSD_SOURCE
emake CC="diet ${CC}" CLFAGS="${CFLAGS}" ${myconf} ||
die "Failed to make diet ${PN}"
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index ae033648b5cd..98fd5d3f30bf 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.98 2004/06/24 22:00:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.99 2004/06/25 20:30:29 agriffis Exp $
+
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org> coreutils-5.0-r6.ebuild,
+ coreutils-5.0.91-r3.ebuild, coreutils-5.0.91-r4.ebuild:
+ QA - fix use invocation
16 Jun 2004; Daniel Black <dragonheart@gentoo.org> coreutils-5.0-r6.ebuild,
coreutils-5.0.91-r3.ebuild, coreutils-5.0.91-r4.ebuild,
diff --git a/sys-apps/coreutils/coreutils-5.0-r6.ebuild b/sys-apps/coreutils/coreutils-5.0-r6.ebuild
index 2a7ea0023f5b..83d568abc434 100644
--- a/sys-apps/coreutils/coreutils-5.0-r6.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r6.ebuild,v 1.9 2004/06/24 22:00:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r6.ebuild,v 1.10 2004/06/25 20:30:29 agriffis Exp $
inherit eutils
@@ -42,7 +42,7 @@ src_unpack() {
# WARNING: These CONFLICT with the SELINUX patches
if use acl
then
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
fi
mv ${PATCHDIR}/{001*,002*,004*} ${PATCHDIR}/excluded
@@ -97,7 +97,7 @@ src_install() {
cd usr/bin
ln -s ../../bin/* .
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild
index b7f248eb1fe9..b1eda5ccd1a3 100644
--- a/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild,v 1.13 2004/06/24 22:00:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r3.ebuild,v 1.14 2004/06/25 20:30:29 agriffis Exp $
inherit eutils flag-o-matic
@@ -70,7 +70,7 @@ src_unpack() {
# This one also needs porting like the rest, but its a bit more involved,
# so I will leave it for somebody that use i18n that can actually test it.
#
- # if [ -z "`use nls`" ] ; then
+ # if ! use nls ; then
mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
# fi
@@ -99,7 +99,7 @@ src_compile() {
if use acl
then
- if [ -z "`use selinux`" ]
+ if ! use selinux
then
if [ -z "`which cvs 2>/dev/null`" ]
then
@@ -139,7 +139,7 @@ src_install() {
cd usr/bin
ln -s ../../bin/* .
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
diff --git a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild b/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
index 2452f4fad168..5808090c90b5 100644
--- a/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild,v 1.19 2004/06/24 22:00:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0.91-r4.ebuild,v 1.20 2004/06/25 20:30:29 agriffis Exp $
inherit eutils flag-o-matic
@@ -70,7 +70,7 @@ src_unpack() {
# This one also needs porting like the rest, but its a bit more involved,
# so I will leave it for somebody that use i18n that can actually test it.
#
- # if [ -z "`use nls`" ] ; then
+ # if ! use nls ; then
mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
# fi
@@ -101,7 +101,7 @@ src_compile() {
if use acl
then
- if [ -z "`use selinux`" ]
+ if ! use selinux
then
if [ -z "`which cvs 2>/dev/null`" ]
then
@@ -149,7 +149,7 @@ src_install() {
cd ../../bin
ln -s ../usr/bin/install .
- if [ -z "`use build`" ]
+ if ! use build
then
cd ${S}
dodoc AUTHORS ChangeLog* COPYING NEWS README* THANKS TODO
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index f43ddeb1d8b0..5f897612a10d 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.8 2004/06/24 22:02:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.9 2004/06/25 20:31:01 agriffis Exp $
+
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org> dbus-0.21.ebuild:
+ QA - fix use invocation
*dbus-0.21 (07 Apr 2004)
diff --git a/sys-apps/dbus/dbus-0.21.ebuild b/sys-apps/dbus/dbus-0.21.ebuild
index c6e173e93e60..729b27aa3bf1 100644
--- a/sys-apps/dbus/dbus-0.21.ebuild
+++ b/sys-apps/dbus/dbus-0.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.21.ebuild,v 1.2 2004/06/24 22:02:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.21.ebuild,v 1.3 2004/06/25 20:31:01 agriffis Exp $
# because of the experimental nature debug by default
inherit debug
@@ -69,7 +69,7 @@ src_install() {
# keepdir /usr/lib/dbus-1.0/services
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
cd ${S}
doxygen Doxyfile
dodir /usr/share/man/man3