summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-28 11:01:45 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-28 11:01:45 +0000
commit5589dbe70ae5d7ffc4b210734e23a910a221b36e (patch)
tree2bd8b6afe546db5c87c6074a47d19210098292fc /sys-apps
parentVersion bump, rename patch files, fix desktop file. (diff)
downloadgentoo-2-5589dbe70ae5d7ffc4b210734e23a910a221b36e.tar.gz
gentoo-2-5589dbe70ae5d7ffc4b210734e23a910a221b36e.tar.bz2
gentoo-2-5589dbe70ae5d7ffc4b210734e23a910a221b36e.zip
Update message about /etc/mtab link (#482786), show message about systemd-ui only when package is not installed (#480606)
(Portage version: 2.1.13.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/systemd-204.ebuild33
-rw-r--r--sys-apps/systemd/systemd-206-r3.ebuild33
3 files changed, 26 insertions, 47 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 76c483b5862b..d8b997579a92 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.167 2013/08/11 21:34:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.168 2013/08/28 11:01:45 pacho Exp $
+
+ 28 Aug 2013; Pacho Ramos <pacho@gentoo.org> systemd-204.ebuild,
+ systemd-206-r3.ebuild:
+ Update message about /etc/mtab link (#482786), show message about systemd-ui
+ only when package is not installed (#480606)
11 Aug 2013; Mike Gilbert <floppym@gentoo.org> systemd-206-r3.ebuild,
systemd-9999-r1.ebuild:
diff --git a/sys-apps/systemd/systemd-204.ebuild b/sys-apps/systemd/systemd-204.ebuild
index 4a72cf10b97b..6e10c3584c22 100644
--- a/sys-apps/systemd/systemd-204.ebuild
+++ b/sys-apps/systemd/systemd-204.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-204.ebuild,v 1.10 2013/08/07 13:20:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-204.ebuild,v 1.11 2013/08/28 11:01:45 pacho Exp $
EAPI=5
@@ -235,20 +235,6 @@ src_install() {
done
}
-optfeature() {
- local i desc=${1} text
- shift
-
- text=" [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- shift
-
- for i; do
- elog "${text}"
- text="& [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- done
- elog "${text} (${desc})"
-}
-
pkg_postinst() {
# for udev rules
enewgroup dialout
@@ -267,17 +253,18 @@ pkg_postinst() {
fi
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
- ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
- ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
- ewarn "require that specific feature, please call:"
- ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ ewarn "Upstream mandates the /etc/mtab file should be a symlink to /proc/mounts."
+ ewarn "Not having it is not supported by upstream and will cause tools like 'df'"
+ ewarn "and 'mount' to not work properly. Please run:"
+ ewarn " # ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
ewarn
fi
- elog "To get additional features, a number of optional runtime dependencies may"
- elog "be installed:"
- optfeature 'for GTK+ systemadm UI and gnome-ask-password-agent' \
- 'sys-apps/systemd-ui'
+ if ! has_version sys-apps/systemd-ui; then
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ elog "- sys-apps/systemd-ui: for GTK+ systemadm UI and gnome-ask-password-agent"
+ fi
}
pkg_prerm() {
diff --git a/sys-apps/systemd/systemd-206-r3.ebuild b/sys-apps/systemd/systemd-206-r3.ebuild
index 1e1f041771a5..5258a0b3378c 100644
--- a/sys-apps/systemd/systemd-206-r3.ebuild
+++ b/sys-apps/systemd/systemd-206-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-206-r3.ebuild,v 1.5 2013/08/11 21:34:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-206-r3.ebuild,v 1.6 2013/08/28 11:01:45 pacho Exp $
EAPI=5
@@ -330,20 +330,6 @@ multilib_src_install_all() {
done
}
-optfeature() {
- local i desc=${1} text
- shift
-
- text=" [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- shift
-
- for i; do
- elog "${text}"
- text="& [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- done
- elog "${text} (${desc})"
-}
-
pkg_postinst() {
# for udev rules
enewgroup dialout
@@ -369,17 +355,18 @@ pkg_postinst() {
fcaps cap_dac_override,cap_sys_ptrace=ep usr/bin/systemd-detect-virt
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
- ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
- ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
- ewarn "require that specific feature, please call:"
- ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ ewarn "Upstream mandates the /etc/mtab file should be a symlink to /proc/mounts."
+ ewarn "Not having it is not supported by upstream and will cause tools like 'df'"
+ ewarn "and 'mount' to not work properly. Please run:"
+ ewarn " # ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
ewarn
fi
- elog "To get additional features, a number of optional runtime dependencies may"
- elog "be installed:"
- optfeature 'for GTK+ systemadm UI and gnome-ask-password-agent' \
- 'sys-apps/systemd-ui'
+ if ! has_version sys-apps/systemd-ui; then
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ elog "- sys-apps/systemd-ui: for GTK+ systemadm UI and gnome-ask-password-agent"
+ fi
}
pkg_prerm() {