summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-06-05 13:10:13 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-06-05 13:10:13 +0000
commit2a1874d73ea6b638af2c214b382d1f684d71da83 (patch)
tree62c844018b4f11e401bf0245ae16937e3eabb6ca /sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild
parentVersion bump; remove v1.3 due to upstream bug #1325579. (diff)
downloadgentoo-2-2a1874d73ea6b638af2c214b382d1f684d71da83.tar.gz
gentoo-2-2a1874d73ea6b638af2c214b382d1f684d71da83.tar.bz2
gentoo-2-2a1874d73ea6b638af2c214b382d1f684d71da83.zip
Revision bump: EAPI 5, epatch_user, respect compiler
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild')
-rw-r--r--sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild b/sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..a94194e71e97
--- /dev/null
+++ b/sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/mpt-status/mpt-status-1.2.0-r1.ebuild,v 1.1 2014/06/05 13:10:13 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Query tool to access the running configuration and status of LSI SCSI HBAs"
+HOMEPAGE="http://www.drugphish.ch/~ratz/mpt-status/"
+SRC_URI="http://www.drugphish.ch/~ratz/mpt-status/${P}.tar.bz2
+ mirror://gentoo/${PN}-1.2.0-linux-sources.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.0-gentoo.patch"
+
+ sed -i -e 's,\(^.*linux/compiler\.h.*$\),,' mpt-status.h || die
+ sed -i -e '/KERNEL_PATH/d' Makefile || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/{AUTHORS,Changelog,DeveloperNotes,FAQ,README,ReleaseNotes,THANKS,TODO}
+}